summaryrefslogtreecommitdiffstats
path: root/abs/extra
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 20:46:11 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 20:46:11 (GMT)
commitfc2b525736a35cf7d5c578fe7737e91818b71e84 (patch)
tree765cc769fc48d0980aa6d42fd47d577a5ff53572 /abs/extra
parent44e5433b2b61c448cab9b610c65781413593e586 (diff)
downloadlinhes_pkgbuild-fc2b525736a35cf7d5c578fe7737e91818b71e84.zip
linhes_pkgbuild-fc2b525736a35cf7d5c578fe7737e91818b71e84.tar.gz
linhes_pkgbuild-fc2b525736a35cf7d5c578fe7737e91818b71e84.tar.bz2
qtwebkit: removed now in core
Diffstat (limited to 'abs/extra')
-rw-r--r--abs/extra/qtwebkit/PKGBUILD38
-rw-r--r--abs/extra/qtwebkit/python2-path.patch29
2 files changed, 0 insertions, 67 deletions
diff --git a/abs/extra/qtwebkit/PKGBUILD b/abs/extra/qtwebkit/PKGBUILD
deleted file mode 100644
index 30f1c84..0000000
--- a/abs/extra/qtwebkit/PKGBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# $Id$
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-
-pkgname=qtwebkit
-pkgver=2.2.0
-pkgrel=3
-arch=('i686' 'x86_64')
-url='http://trac.webkit.org/wiki/QtWebKit'
-pkgdesc='An open source web browser engine (Qt port)'
-license=('LGPL2.1' 'GPL3')
-depends=('qt' 'gperf' 'bison' 'phonon' 'gstreamer0.10-base')
-makedepends=('python2' 'mesa' 'chrpath')
-conflicts=('qt<4.7')
-source=("http://get.qt.nokia.com/${pkgname}/QtWebKit-${pkgver}.tar.gz"
- 'python2-path.patch')
-sha1sums=('3582f3a8b593140af004a19479f5ec19693b3df7'
- 'b0ef3d5596171e3900a685df9bcfac3068ad6330')
-
-build() {
- cd "${srcdir}"/QtWebKit-${pkgver}
-
- patch -p1 -i "${srcdir}"/python2-path.patch
-
- cd Tools/Scripts
- ./build-webkit --qt \
- --prefix=/usr \
- --makeargs="${MAKEFLAGS}" \
- --release \
- --3d-canvas
-}
-
-package() {
- cd "${srcdir}"/QtWebKit-${pkgver}
- make INSTALL_ROOT="${pkgdir}" -C WebKitBuild/Release install
-
- # Fix RPATH
- chrpath -r /usr/lib/ "${pkgdir}"/usr/lib/qt/imports/QtWebKit/libqmlwebkitplugin.so
-}
diff --git a/abs/extra/qtwebkit/python2-path.patch b/abs/extra/qtwebkit/python2-path.patch
deleted file mode 100644
index 2e270e6..0000000
--- a/abs/extra/qtwebkit/python2-path.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- QtWebKit-2.2.0/Source/JavaScriptCore/DerivedSources.pro~ 2011-10-20 22:39:56.044519075 +0000
-+++ QtWebKit-2.2.0/Source/JavaScriptCore/DerivedSources.pro 2011-10-20 22:41:21.302047082 +0000
-@@ -88,5 +88,5 @@
- retgen.output = $$JSC_GENERATED_SOURCES_DIR/RegExpJitTables.h
- retgen.wkScript = $$PWD/create_regex_tables
- retgen.input = retgen.wkScript
--retgen.commands = python $$retgen.wkScript > ${QMAKE_FILE_OUT}
-+retgen.commands = python2 $$retgen.wkScript > ${QMAKE_FILE_OUT}
- addExtraCompiler(retgen)
---- QtWebKit-2.2.0/Source/WebCore/CodeGenerators.pri~ 2011-10-20 22:44:23.827225580 +0000
-+++ QtWebKit-2.2.0/Source/WebCore/CodeGenerators.pri 2011-10-20 22:44:38.550707819 +0000
-@@ -640,7 +640,7 @@
- inspectorJSON.output = $${WC_GENERATED_SOURCES_DIR}/Inspector.idl
- inspectorJSON.input = INSPECTOR_JSON
- inspectorJSON.wkScript = $$PWD/inspector/generate-inspector-idl
--inspectorJSON.commands = python $$inspectorJSON.wkScript -o $${WC_GENERATED_SOURCES_DIR}/Inspector.idl $$PWD/inspector/Inspector.json
-+inspectorJSON.commands = python2 $$inspectorJSON.wkScript -o $${WC_GENERATED_SOURCES_DIR}/Inspector.idl $$PWD/inspector/Inspector.json
- inspectorJSON.depends = $$PWD/inspector/generate-inspector-idl
- inspectorJSON.wkAddOutputToSources = false
- addExtraCompiler(inspectorJSON)
-@@ -723,7 +723,7 @@
- entities.output = $${WC_GENERATED_SOURCES_DIR}/HTMLEntityTable.cpp
- entities.input = HTML_ENTITIES
- entities.wkScript = $$PWD/html/parser/create-html-entity-table
--entities.commands = python $$entities.wkScript -o $${WC_GENERATED_SOURCES_DIR}/HTMLEntityTable.cpp $$HTML_ENTITIES
-+entities.commands = python2 $$entities.wkScript -o $${WC_GENERATED_SOURCES_DIR}/HTMLEntityTable.cpp $$HTML_ENTITIES
- entities.clean = ${QMAKE_FILE_OUT}
- entities.depends = $$PWD/html/parser/create-html-entity-table
- addExtraCompiler(entities)