summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/MythVantage-config
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-28 17:23:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-28 17:23:00 (GMT)
commite64ae16a10e7c506efbfd473d8738eddd7c46c7b (patch)
treea3987a78d87ad6665093961afabde7ef6b28c0c2 /abs/mv-core/MythVantage-config
parent9ea091d177fe86f5d2e1e9b7bc4aed3c08101935 (diff)
downloadlinhes_pkgbuild-e64ae16a10e7c506efbfd473d8738eddd7c46c7b.zip
linhes_pkgbuild-e64ae16a10e7c506efbfd473d8738eddd7c46c7b.tar.gz
linhes_pkgbuild-e64ae16a10e7c506efbfd473d8738eddd7c46c7b.tar.bz2
-fix timezip to support region/subregion.
-Restore sudo all for the mythtv user
Diffstat (limited to 'abs/mv-core/MythVantage-config')
-rwxr-xr-xabs/mv-core/MythVantage-config/PKGBUILD2
-rwxr-xr-xabs/mv-core/MythVantage-config/timezip.py43
2 files changed, 44 insertions, 1 deletions
diff --git a/abs/mv-core/MythVantage-config/PKGBUILD b/abs/mv-core/MythVantage-config/PKGBUILD
index 0a1178b..377083b 100755
--- a/abs/mv-core/MythVantage-config/PKGBUILD
+++ b/abs/mv-core/MythVantage-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=MythVantage-config
pkgver=3.2
-pkgrel=141
+pkgrel=142
pkgdesc="The Gui-installer"
depends=(bc mysql-python expect curl dnsutils sg3_utils parted)
arch=('i686')
diff --git a/abs/mv-core/MythVantage-config/timezip.py b/abs/mv-core/MythVantage-config/timezip.py
index 7a35475..18f338f 100755
--- a/abs/mv-core/MythVantage-config/timezip.py
+++ b/abs/mv-core/MythVantage-config/timezip.py
@@ -20,6 +20,8 @@ def printvars():
print "BEhostname:" + BEhostname
print "zipcode:" + zipcode
print "timezone:" + tz
+ print "timezone region:" + tz_region
+ print "timezone subregion:" + tz_subregion
print "nfsip:" + nfsip
print "nfstoggle:" + nfstoggle
print "nfsmount:" + nfsmount
@@ -30,6 +32,8 @@ def selectvars():
global BEhostname
global zipcode
global tz
+ global tz_region
+ global tz_subregion
global nfsip
global nfstoggle
global nfsmount
@@ -77,7 +81,22 @@ def selectvars():
tz=result[0]
except TypeError:
tz=""
+##########
+ cursor.execute("select data from settings where value='HostTimeZoneRegion' and hostname=(%s)",(BEhostname))
+ result = cursor.fetchone()
+ try:
+ tz_region=result[0]
+ except TypeError:
+ tz=""
+ tempsubregion="HostTimeZoneRegion_" + tz_region
+ cursor.execute("select data from settings where value=%s and hostname=(%s)",(tempsubregion,BEhostname))
+ result = cursor.fetchone()
+ try:
+ tz_subregion=result[0]
+ except TypeError:
+ tz_subregion=""
+###############
if ( thishostname != BEhostname ):
cursor.execute("select data from settings where value='GlobalServiceHobbitserver'")
result = cursor.fetchone()
@@ -114,6 +133,27 @@ def insertvars():
cursor.execute("update settings set data=(%s) where hostname=(%s) and value='HostTimeZone'",(tz,thishostname))
print "updating timezone"
+ cursor.execute("select * from settings where value='HostTimeZoneRegion' and hostname=(%s)",(thishostname))
+ result = cursor.fetchone()
+ if ( tz != ""):
+ if (result == None):
+ cursor.execute("INSERT INTO settings (value,data,hostname) VALUES ('HostTimeZoneRegion',(%s),(%s))",(tz_region,thishostname))
+ print "inserting timezone region"
+ else:
+ cursor.execute("update settings set data=(%s) where hostname=(%s) and value='HostTimeZoneRegion'",(tz_region,thishostname))
+ print "updating timezone region"
+
+ tempsubregion="HostTimeZoneRegion_" + tz_region
+ cursor.execute("select * from settings where value=%s and hostname=(%s)",(tempsubregion,thishostname))
+ result = cursor.fetchone()
+ if ( tz != ""):
+ if (result == None):
+ cursor.execute("INSERT INTO settings (value,data,hostname) VALUES ((%s),(%s),(%s))",(tempsubregion,tz_subregion,thishostname))
+ print "inserting timezone subregion"
+ else:
+ cursor.execute("update settings set data=(%s) where hostname=(%s) and value=(%s)",(tempsubregion,tz_subregion,thishostname))
+ print "updating timezone subregion"
+
#start of NFSIP
cursor.execute("select data from settings where value='HostCentralNFSIP' and hostname=(%s)",(thishostname))
@@ -157,6 +197,9 @@ def main(argv):
global BEhostname
global zipcode
global tz
+ global tz_region
+ global tz_subregion
+
global nfsip
global hobbitclient
try: