summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/MythVantage-system/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-09 03:14:58 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-09 03:14:58 (GMT)
commit5445907db788ab2c7c73ea19fc47d59c862fc6a3 (patch)
tree1b0a868eb5b9d6aa8e7835cbc49c05947b7c75fe /abs/mv-core/MythVantage-system/PKGBUILD
parentabc83d46637ebc63479ec745f05ae392f404f04e (diff)
downloadlinhes_pkgbuild-5445907db788ab2c7c73ea19fc47d59c862fc6a3.zip
linhes_pkgbuild-5445907db788ab2c7c73ea19fc47d59c862fc6a3.tar.gz
linhes_pkgbuild-5445907db788ab2c7c73ea19fc47d59c862fc6a3.tar.bz2
MythVantage-config (replaces live-installer) for MythVantage
MythVanate-system (replaces STB-system)
Diffstat (limited to 'abs/mv-core/MythVantage-system/PKGBUILD')
-rw-r--r--abs/mv-core/MythVantage-system/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/abs/mv-core/MythVantage-system/PKGBUILD b/abs/mv-core/MythVantage-system/PKGBUILD
new file mode 100644
index 0000000..7f01ac0
--- /dev/null
+++ b/abs/mv-core/MythVantage-system/PKGBUILD
@@ -0,0 +1,43 @@
+pkgname=MythVantage-system
+pkgver=1.0
+pkgrel=1
+arch=('i686')
+MVDIR=$startdir/pkg/usr/MythVantage
+BINDIR=$startdir/pkg/usr/bin
+install=STB.install
+pkgdesc="scripts and things related to having a automated system"
+depends=(unclutter ghosd ncid func wol )
+provides=(STB-system)
+
+binfiles="playmedia.sh STB-start saytime.sh restartfrontend.sh backup_job restore_job.sh update_system update_system_all repo_sync.sh backend_control.sh load-modules-mythvantage.sh file_time_offset.py grabkey.py imdb-bulk-update.pl notify.py optimize_mythdb.py myth_mtc.py myth_mtc.sh firstboot.sh initial_db_run"
+
+source=(startfrontend inittab STBWINDOWMANAGER smolt.cron $binfiles mfegdbcommands.txt mbegdbcommands.txt 45-event.rules)
+
+build() {
+ cd $startdir/src
+ install -m755 -D STBWINDOWMANAGER $startdir/pkg/etc/X11/STBWINDOWMANAGER
+ install -m755 -D startfrontend $startdir/pkg/etc/X11/Sessions/STB
+ install -m755 -D mfegdbcommands.txt $MVDIR/mfegdbcommands.txt
+ install -m755 -D mbegdbcommands.txt $MVDIR/mbegdbcommands.txt
+####### install to /usr/MythVantage/bin/
+mkdir -p $BINDIR
+for i in $binfiles
+do
+ item=$i
+ install -m755 -D $item $MVDIR/bin/$item
+ echo $item
+ cd $BINDIR
+ pwd
+ ln -s ../MythVantage/bin/$i .
+
+ cd -
+done
+##########
+
+ install -m755 -D smolt.cron $startdir/pkg/etc/cron.weekly/smolt.cron
+
+ install -m755 -D 45-event.rules $startdir/pkg/etc/udev/rules.d/45-event.rules
+
+
+}
+