summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/certmaster/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-02-26 20:44:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-02-26 20:44:21 (GMT)
commit0d29973b73419a2baa101234e0f19d3d19bb6de2 (patch)
treeb756edcdae028b298bb344bafb7fa8e3f2682894 /abs/mv-core/certmaster/PKGBUILD
parent49aae8b40acb600a58e0202cb83e2f194db47690 (diff)
downloadlinhes_pkgbuild-0d29973b73419a2baa101234e0f19d3d19bb6de2.zip
linhes_pkgbuild-0d29973b73419a2baa101234e0f19d3d19bb6de2.tar.gz
linhes_pkgbuild-0d29973b73419a2baa101234e0f19d3d19bb6de2.tar.bz2
splitting certmaster out from func
Diffstat (limited to 'abs/mv-core/certmaster/PKGBUILD')
-rw-r--r--abs/mv-core/certmaster/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/mv-core/certmaster/PKGBUILD b/abs/mv-core/certmaster/PKGBUILD
new file mode 100644
index 0000000..96b8d2c
--- /dev/null
+++ b/abs/mv-core/certmaster/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=certmaster
+pkgver=0.24
+pkgrel=5
+pkgdesc="certmaster"
+url=""
+license="gpl"
+depends=(pyopenssl)
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+moddir="pkg/usr/lib/python2.5/site-packages/func/minion/modules/"
+backup=('etc/certmaster/certmaster.conf' 'etc/certmaster/minion.conf')
+
+
+source=($pkgname-$pkgver.tar.gz certmaster.conf minion.conf)
+md5sums=()
+arch=('i686')
+
+build() {
+ cd $startdir/src/$pkgname-${pkgver}
+ python setup.py build
+ python setup.py install --prefix=$startdir/pkg/usr
+ cd $startdir/src
+ install -m755 -D minion.conf $startdir/pkg/etc/certmaster/minion.conf
+ install -m755 -D certmaster.conf $startdir/pkg/etc/certmaster/certmaster.conf
+ mkdir -p $startdir/pkg/var/log/certmaster
+ cd $startdir/pkg
+ find ./ -name "*.pyc" -print | xargs rm -f
+}