summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/keylaunch
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
commit1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e (patch)
treef336ee91ce16c6591fff50340562e07e15aa1a55 /abs/mv-core/keylaunch
parent75b1bceb21faab32d8f519d6f7f7062a226f9047 (diff)
downloadlinhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.zip
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.gz
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.bz2
MythVantage specific pkgs
Diffstat (limited to 'abs/mv-core/keylaunch')
-rw-r--r--abs/mv-core/keylaunch/PKGBUILD17
-rw-r--r--abs/mv-core/keylaunch/example_rc19
-rwxr-xr-xabs/mv-core/keylaunch/keylaunch.install40
3 files changed, 76 insertions, 0 deletions
diff --git a/abs/mv-core/keylaunch/PKGBUILD b/abs/mv-core/keylaunch/PKGBUILD
new file mode 100644
index 0000000..f900c7a
--- /dev/null
+++ b/abs/mv-core/keylaunch/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=keylaunch
+pkgver=1.3.3
+pkgrel=10
+arch=('i686')
+pkgdesc="KeyLaunch is a small utility for binding commands to a hot key. "
+url="http://www.oroborus.org/"
+depends=(glibc)
+source=(http://www.oroborus.org/debian/dists/sid/main/source/x11/keylaunch_1.3.3.tar.gz example_rc)
+install=keylaunch.install
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+ make DESTDIR=$startdir/pkg install
+ install -D -m0755 ../example_rc $startdir/pkg/etc/keylaunchrc
+}
diff --git a/abs/mv-core/keylaunch/example_rc b/abs/mv-core/keylaunch/example_rc
new file mode 100644
index 0000000..ed6519e
--- /dev/null
+++ b/abs/mv-core/keylaunch/example_rc
@@ -0,0 +1,19 @@
+# Copy to $HOME/.keylaunchrc
+#
+# Format:
+# key=...KeyName:Command
+#
+# ... No modifier
+# *.. Shift
+# .*. Ctrl
+# ..* Alt
+
+#key=..*Return:xterm
+key=.*.Return:rxvt
+key=*..Return:terminal
+key=..*S:sudo /usr/local/bin/mythtv-setup
+key=.**U:killall -9 unclutter
+key=..*h:/usr/MythVantage/bin/mythinstall -h
+key=..*1:/usr/MythVantage/bin/mythbeselect -stop
+key=..*2:/usr/MythVantage/bin/mythbeselect -start
+key=..*3:/usr/MythVantage/bin/mythbeselect -restart
diff --git a/abs/mv-core/keylaunch/keylaunch.install b/abs/mv-core/keylaunch/keylaunch.install
new file mode 100755
index 0000000..ade2c7b
--- /dev/null
+++ b/abs/mv-core/keylaunch/keylaunch.install
@@ -0,0 +1,40 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ ln -s /etc/keylaunchrc /data/home/mythtv/.keylaunchrc
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*