summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/lcdproc/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-09 02:33:06 (GMT)
commit1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e (patch)
treef336ee91ce16c6591fff50340562e07e15aa1a55 /abs/mv-core/lcdproc/PKGBUILD
parent75b1bceb21faab32d8f519d6f7f7062a226f9047 (diff)
downloadlinhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.zip
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.gz
linhes_pkgbuild-1ba69cc033dfbd0a6c4c29c6d877c7e753f96e8e.tar.bz2
MythVantage specific pkgs
Diffstat (limited to 'abs/mv-core/lcdproc/PKGBUILD')
-rwxr-xr-xabs/mv-core/lcdproc/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/mv-core/lcdproc/PKGBUILD b/abs/mv-core/lcdproc/PKGBUILD
new file mode 100755
index 0000000..cb536e9
--- /dev/null
+++ b/abs/mv-core/lcdproc/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=lcdproc
+#pkgver=0.5.2
+pkgver=20080326
+pkgrel=7
+pkgdesc="LCDproc is a utility to drive one or more LCD (and LCD-like) devices attached to a host."
+url="http://lcdproc.omnipotent.net/"
+license="GPL"
+depends=(libusb xosd)
+backup=(etc/LCDd.conf)
+arch=('i686')
+#source=(http://switch.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz lcdd mythvantage.patch)
+source=(lcdproc-CVS-current.tar.gz lcdd mythvantage.patch)
+
+build() {
+ #cd $startdir/src/$pkgname-$pkgver
+ cd $startdir/src/$pkgname-CVS-current-$pkgver
+# lcdproc-CVS-current-20080326
+ patch -p0 < ../mythvantage.patch
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-libusb --enable-drivers=all
+ make
+ make DESTDIR=$startdir/pkg install
+ sed -e "s/server\/drivers\//\/usr\/lib\/lcdproc\//g" LCDd.conf > $startdir/pkg/etc/LCDd.conf
+ mkdir -p $startdir/pkg/etc/rc.d
+ install -m 755 $startdir/src/lcdd $startdir/pkg/etc/rc.d
+}