summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/release-fixes/plugins/mythmusic
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-02-22 22:33:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-02-22 22:33:38 (GMT)
commit8a56d9ef0cf6ddd18fa9f1065d915c7688f54d17 (patch)
treeb8da8aaafce30effaaf968d294ed776b002e5fcb /abs/mv-core/myth/release-fixes/plugins/mythmusic
parent0e3fd5d95beeec6ea3b0f763646549e19899814b (diff)
downloadlinhes_pkgbuild-8a56d9ef0cf6ddd18fa9f1065d915c7688f54d17.zip
linhes_pkgbuild-8a56d9ef0cf6ddd18fa9f1065d915c7688f54d17.tar.gz
linhes_pkgbuild-8a56d9ef0cf6ddd18fa9f1065d915c7688f54d17.tar.bz2
Bring MV-core myth packages up to date
Diffstat (limited to 'abs/mv-core/myth/release-fixes/plugins/mythmusic')
-rw-r--r--abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD24
-rw-r--r--abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch37
2 files changed, 12 insertions, 49 deletions
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
index de26f57..bfb1de5 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
@@ -5,12 +5,15 @@ pkgdesc="Music playing plugin for MythTV"
url="http://www.mythtv.org"
arch=('i686' 'x86_64')
-depends=('mythtv-release-fixes ' 'libid3tag' 'flac>=1.1.4 ' 'a52dec' 'libcdaudio' 'libcddb' 'libdvdread' 'libid3tag' 'libmad' 'libogg' 'libtheora' 'libvorbis' 'taglib' 'libvisual' 'cdparanoia' 'sdl' 'faad2' 'lame' 'fftw2')
+
+depends=("mythtv-release-fixes>=${pkgver}" 'libid3tag' 'libmad' 'libvorbis' 'flac>=1.1.4' 'libcdaudio' \
+ 'cdparanoia' 'fftw2' 'sdl' 'faad2>=2.6.1' 'lame' 'taglib' \
+ 'libvisual-plugins' 'libvisual-projectm')
conflicts=('mythtv-plugins-release-fixes')
groups=('mythtv-all-plugins-release-fixes')
license="GPL"
-source=(gcc4.3.patch)
+source=()
_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
_svnmod=mythplugins
@@ -20,20 +23,17 @@ build() {
echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
cd $startdir/src/mythplugins/mythmusic
- patch -p1 < ../../gcc4.3.patch
+# patch -p1 < ../../gcc4.3.patch
cd $startdir/src/mythplugins
- ./configure --disable-all --enable-mythmusic --enable-fftw --enable-sdl --disable-aac --enable-opengl
-PLUGIN=mythmusic
-grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
-if [ $? != 0 ]
-then
+ ./configure --disable-all --enable-mythmusic --enable-fftw --enable-sdl --disable-aac --enable-opengl --prefix=/usr
+ PLUGIN=mythmusic
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
msg "appending program lib"
- fi
-
-# ./configure --disable-all --enable-mythmusic
+ fi
make || return 1
-
make INSTALL_ROOT=$startdir/pkg install
}
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch b/abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch
deleted file mode 100644
index 564c434..0000000
--- a/abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Index: mythmusic/mythmusic/aacdecoder.cpp
-===================================================================
---- mythmusic/mythmusic/aacdecoder.cpp (revision 17452)
-+++ mythmusic/mythmusic/aacdecoder.cpp (working copy)
-@@ -19,6 +19,7 @@
- #include <qobject.h>
- #include <qiodevice.h>
- #include <qfile.h>
-+#include <stdlib.h>
-
- #include "aacdecoder.h"
- #include "constants.h"
-Index: mythmusic/mythmusic/aacdecoder.h
-===================================================================
---- mythmusic/mythmusic/aacdecoder.h (revision 17452)
-+++ mythmusic/mythmusic/aacdecoder.h (working copy)
-@@ -51,7 +51,7 @@
- bool done, finish;
- long len, bitrate;
- uchar channels;
-- unsigned long sample_rate;
-+ uint32_t sample_rate;
- unsigned long output_size;
- double totalTime, seekTime;
-
-Index: mythmusic/mythmusic/metaiomp4.cpp
-===================================================================
---- mythmusic/mythmusic/metaiomp4.cpp (revision 17452)
-+++ mythmusic/mythmusic/metaiomp4.cpp (working copy)
-@@ -3,6 +3,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <sys/types.h>
-+#include <stdlib.h>
-
- using namespace std;
-