summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythphone/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-17 17:16:31 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-17 17:16:31 (GMT)
commit997dbedae9ea47fbb46ec15f8827cf1a8065c11e (patch)
treee20e579880f339682d8ede709369769269a365e0 /abs/mv-core/myth/stable/mythphone/PKGBUILD
parentda98b0f401f135cb5a04270dbfc46c5dafc43d9d (diff)
downloadlinhes_pkgbuild-997dbedae9ea47fbb46ec15f8827cf1a8065c11e.zip
linhes_pkgbuild-997dbedae9ea47fbb46ec15f8827cf1a8065c11e.tar.gz
linhes_pkgbuild-997dbedae9ea47fbb46ec15f8827cf1a8065c11e.tar.bz2
mv-core: bring it up to date so that it works again
Diffstat (limited to 'abs/mv-core/myth/stable/mythphone/PKGBUILD')
-rw-r--r--abs/mv-core/myth/stable/mythphone/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/mv-core/myth/stable/mythphone/PKGBUILD b/abs/mv-core/myth/stable/mythphone/PKGBUILD
new file mode 100644
index 0000000..7fd3b46
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythphone/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=mythphone-release-fixes
+pkgver=21228
+pkgrel=1
+pkgdesc="Plugin that allows phone calls to be made to MythTv"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-release-fixes')
+conflicts=('mythtv-plugins-release-fixes')
+groups=('mythtv-all-plugins-release-fixes')
+license="GPL"
+source=()
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svnmod=mythplugins
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ make distclean
+ PLUGIN=mythphone
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+
+ msg "Correcting configure kde3 to kde"
+ sed -i 's#kde3#kde#' configure || return 1
+ ./configure --prefix=/usr --enable-opengl --disable-all --enable-mythphone || return 1
+ qmake mythplugins.pro || return 1
+ make qmake || return 1
+
+ msg "Correcting Makefile kde3 to kde"
+ sed -i 's#kde3#kde#' ./mythphone/mythphone/Makefile || return 1
+
+ make -j 2 || return 1
+ make INSTALL_ROOT=$startdir/pkg install
+}
+