summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/myth/stable/mythphone/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-08-18 04:11:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-08-18 04:11:57 (GMT)
commita1521d388a79d6792af788406224c3963e77c765 (patch)
tree2bda56e29a3b5f7ff7621f4b1df9d2eca405aba0 /abs/mv-core/myth/stable/mythphone/PKGBUILD
parent4a416bea72be751fe503edebe21c8708c0e5dce4 (diff)
parent9800bb0789a9b3655a679e996841bdb51a609d22 (diff)
downloadlinhes_pkgbuild-a1521d388a79d6792af788406224c3963e77c765.zip
linhes_pkgbuild-a1521d388a79d6792af788406224c3963e77c765.tar.gz
linhes_pkgbuild-a1521d388a79d6792af788406224c3963e77c765.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core/myth/stable/mythphone/PKGBUILD')
-rw-r--r--abs/mv-core/myth/stable/mythphone/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/mv-core/myth/stable/mythphone/PKGBUILD b/abs/mv-core/myth/stable/mythphone/PKGBUILD
new file mode 100644
index 0000000..7fd3b46
--- /dev/null
+++ b/abs/mv-core/myth/stable/mythphone/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=mythphone-release-fixes
+pkgver=21228
+pkgrel=1
+pkgdesc="Plugin that allows phone calls to be made to MythTv"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-release-fixes')
+conflicts=('mythtv-plugins-release-fixes')
+groups=('mythtv-all-plugins-release-fixes')
+license="GPL"
+source=()
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
+_svnmod=mythplugins
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ make distclean
+ PLUGIN=mythphone
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+
+ msg "Correcting configure kde3 to kde"
+ sed -i 's#kde3#kde#' configure || return 1
+ ./configure --prefix=/usr --enable-opengl --disable-all --enable-mythphone || return 1
+ qmake mythplugins.pro || return 1
+ make qmake || return 1
+
+ msg "Correcting Makefile kde3 to kde"
+ sed -i 's#kde3#kde#' ./mythphone/mythphone/Makefile || return 1
+
+ make -j 2 || return 1
+ make INSTALL_ROOT=$startdir/pkg install
+}
+