summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/oss-sound/oss-linux-free/oss.install
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-11-30 04:11:03 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-11-30 04:11:03 (GMT)
commitf78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f (patch)
tree35b4ab3030640a144537124112e3d65d138672f5 /abs/mv-core/oss-sound/oss-linux-free/oss.install
parentfba7ea15ad46f8655bf17ab4c1cc5a8228d39e1b (diff)
parentf0da28db238a7c58552446e2d87bae48a0f9718b (diff)
downloadlinhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.zip
linhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.tar.gz
linhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core/oss-sound/oss-linux-free/oss.install')
-rw-r--r--abs/mv-core/oss-sound/oss-linux-free/oss.install40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/mv-core/oss-sound/oss-linux-free/oss.install b/abs/mv-core/oss-sound/oss-linux-free/oss.install
new file mode 100644
index 0000000..e17dd0e
--- /dev/null
+++ b/abs/mv-core/oss-sound/oss-linux-free/oss.install
@@ -0,0 +1,40 @@
+post_install() {
+ echo "Probing soundcards, change /usr/lib/oss/etc/installed_drivers as needed afterwards if
+ you want to disable any of the OSS modules. You can run '/usr/sbin/ossdetect -v' at any time
+ if you have changed soundcards."
+ /usr/sbin/ossdetect -v
+ /sbin/ldconfig
+ /bin/true
+}
+
+pre_upgrade() {
+ /etc/rc.d/oss-linux-free stop
+ /bin/true
+}
+
+post_upgrade() {
+ /etc/rc.d/oss-linux-free start
+ echo "If you changed your soundcard, reprobe for soundcards using '/usr/sbin/ossdetect -v'."
+ /sbin/ldconfig # We need to run this since libflashsupport.so is installed on x86
+ /bin/true
+}
+
+pre_remove() {
+ /etc/rc.d/oss-linux-free stop
+ sh /usr/lib/oss/scripts/restore_drv.sh
+}
+
+post_remove() {
+ echo "/usr/lib/oss/ will still contain files after removal as those files were generated by OSS
+ after instalation. Delete them manually unless you want to keep them for later use."
+ if [ `uname -m` == "i686" ]; then
+ rm -f /usr/lib/libflashsupport.so
+ fi
+ /bin/true
+}
+
+op=$1
+shift
+[ "$(type -t "$op")" = "function" ] && $op "$@"
+
+# vim:set ts=2 sw=2 et: