summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/runit-scripts-mv/runitscripts/1
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-28 09:08:13 (GMT)
commit428e5178d79eb900bbe515665b2d6c6a4b0d0f89 (patch)
tree5cf7c10428f1d0afe62eeee70105bd447ea69b99 /abs/mv-core/runit-scripts-mv/runitscripts/1
parentf6276f03790fc2302054a8242339def7b6792557 (diff)
parent568da1387066e54f0eceb57fd8f53bd0eba87974 (diff)
downloadlinhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.zip
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.gz
linhes_pkgbuild-428e5178d79eb900bbe515665b2d6c6a4b0d0f89.tar.bz2
Merge branch 'master' of ssh://gregfrost@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core/runit-scripts-mv/runitscripts/1')
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/116
1 files changed, 14 insertions, 2 deletions
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/1 b/abs/mv-core/runit-scripts-mv/runitscripts/1
index 748930f..6e4425d 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/1
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/1
@@ -1,14 +1,26 @@
#!/bin/bash
/etc/rc.sysinit
+. /etc/rc.conf
+. /etc/rc.d/functions
hostname `cat /etc/hostname`
/sbin/sysctl -p 2>/dev/null >/dev/null
-#/usr/bin/load-modules-mythvantage.sh
+#yes it's needed the 2nd time
+/usr/LH/bin/load-modules-mythvantage.sh >/dev/null
rm /etc/dhcpc/dhcpcd*.pid 2>/dev/null
rm -f /etc/sv/frontend/.runtime/* 2>/dev/null
rm -f /etc/runit/reboot 2>/dev/null
+stat_busy "Starting network"
/etc/net/scripts/network.init start 2>/var/log/network.init.error >/var/log/network.init
+stat_done
/usr/sbin/ethtool -s eth0 wol g 2>/dev/null
/usr/sbin/ethtool -s eth1 wol g 2>/dev/null
/usr/sbin/ethtool -s eth2 wol g 2>/dev/null
+#user added stuff for level 1 of runit
+if [ -e /etc/runit/1.local ]
+then
+ #exec the file
+ stat_busy /etc/runit/1.local
+ /etc/runit/1.local
+ stat_done
+fi
-#/bin/su mythtv -c /usr/bin/grabkey.py 2>/dev/null 1>/devn/null &