summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/runit-scripts-mv
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-08-29 16:29:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-08-29 16:29:01 (GMT)
commit25c30209666f591371476d272712e92e7173ce7c (patch)
tree6ea95b7567b6a094af18832bc36953b3f28dd12f /abs/mv-core/runit-scripts-mv
parent3eeb924c21ef82a144d1fa48c3dd2d571ea4f9bc (diff)
downloadlinhes_pkgbuild-25c30209666f591371476d272712e92e7173ce7c.zip
linhes_pkgbuild-25c30209666f591371476d272712e92e7173ce7c.tar.gz
linhes_pkgbuild-25c30209666f591371476d272712e92e7173ce7c.tar.bz2
mv-core: add fbsplash-runit
Diffstat (limited to 'abs/mv-core/runit-scripts-mv')
-rwxr-xr-xabs/mv-core/runit-scripts-mv/PKGBUILD18
-rwxr-xr-xabs/mv-core/runit-scripts-mv/fbsplash-runit.sh27
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/12
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/acpid/log/run6
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/alsa-utils/run3
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/certmaster/run3
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/frontend/log/run3
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run1
-rwxr-xr-xabs/mv-core/runit-scripts-mv/runitscripts/services/smartd/run22
9 files changed, 61 insertions, 24 deletions
diff --git a/abs/mv-core/runit-scripts-mv/PKGBUILD b/abs/mv-core/runit-scripts-mv/PKGBUILD
index 04b2c92..d4e8dc3 100755
--- a/abs/mv-core/runit-scripts-mv/PKGBUILD
+++ b/abs/mv-core/runit-scripts-mv/PKGBUILD
@@ -1,28 +1,30 @@
-pkgname=runit-scripts-mv
+pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=7
-pkgdesc="collection of startup scripts for runit MythVantage styel"
+pkgrel=301
+pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
depends=('glibc' 'util-linux' 'initscripts' 'runit' )
-makedepends=()
+makedepends=('rsync')
conflicts=()
replaces=()
-backup=()
+backup=(etc/runit/1.local)
install=runit.install
-source=()
+source=(fbsplash-runit.sh)
arch=('i686')
build() {
- rsync -a --exclude=.svn $startdir/runitscripts $startdir/src
+ rsync -a --exclude=.svn --exclude=*~ $startdir/runitscripts $startdir/src
cd $startdir/src/runitscripts
install -d $startdir/pkg/etc/
install -d $startdir/pkg/etc/runit/
install -d $startdir/pkg/var/service
install -d $startdir/pkg/etc/sv
install -d $startdir/pkg/sbin
- install -m0700 1 2 3 ctrlaltdel $startdir/pkg/etc/runit
+ install -d $startdir/pkg/etc/rc.d/functions.d
+ install -m0700 1 2 3 1.local ctrlaltdel $startdir/pkg/etc/runit
+ install -m755 $startdir/src/fbsplash-runit.sh $startdir/pkg/etc/rc.d/functions.d/fbsplash-runit.sh
install -m0755 reboot-runit halt-runit logger $startdir/pkg/sbin
rsync -a --exclude=.svn services/* $startdir/pkg/etc/sv
}
diff --git a/abs/mv-core/runit-scripts-mv/fbsplash-runit.sh b/abs/mv-core/runit-scripts-mv/fbsplash-runit.sh
new file mode 100755
index 0000000..aa391b0
--- /dev/null
+++ b/abs/mv-core/runit-scripts-mv/fbsplash-runit.sh
@@ -0,0 +1,27 @@
+# fbsplash function.d script #
+# Author: Greg Helton <gt@fallendusk.org> #
+
+# Who is calling? #
+CALLER=$0
+
+# splash stuff #
+. /etc/conf.d/fbsplash.conf
+. /sbin/splash-functions.sh
+
+# Redefine the stat functions #
+
+stat_runit() {
+ printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
+ printf "${SAVE_POSITION}"
+ deltext
+ printf " ${C_OTHER}[${C_BUSY}BKGD${C_OTHER}]${C_CLEAR} "
+ # Load variables #
+ var_load STEP_NR MAX_STEPS RC_MULTI RC_SYSINIT RC_SHUTDOWN
+ # Only update the splash progress if we're in sysinit, multi, or shutdown. #
+ ((SPLASH_STEP_NR++))
+ SPLASH_PROGRESS=$((100*${SPLASH_STEP_NR}/${SPLASH_MAX_STEPS}))
+ SPLASH_CURRENT_PROGRESS=${SPLASH_PROGRESS}
+ splash_update_progress ${SPLASH_PROGRESS}
+ var_save STEP_NR CURRENT_PROGRESS
+
+}
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/1 b/abs/mv-core/runit-scripts-mv/runitscripts/1
index 6e4425d..79381ea 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/1
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/1
@@ -5,7 +5,7 @@
hostname `cat /etc/hostname`
/sbin/sysctl -p 2>/dev/null >/dev/null
#yes it's needed the 2nd time
-/usr/LH/bin/load-modules-mythvantage.sh >/dev/null
+/usr/MythVantage/bin/load-modules-mythvantage.sh >/dev/null
rm /etc/dhcpc/dhcpcd*.pid 2>/dev/null
rm -f /etc/sv/frontend/.runtime/* 2>/dev/null
rm -f /etc/runit/reboot 2>/dev/null
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/acpid/log/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/acpid/log/run
index 20c892e..d00b44d 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/acpid/log/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/acpid/log/run
@@ -1,8 +1,8 @@
#!/bin/sh
exec 2>&1
-#export TERM=linux
-#. /etc/rc.conf
-#. /etc/rc.d/functions
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
#stat_runit "Starting MythBackend logger"
/usr/bin/logger -p info -t acpid
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/alsa-utils/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/alsa-utils/run
index 17f5f99..fe5e905 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/alsa-utils/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/alsa-utils/run
@@ -1,3 +1,6 @@
#!/bin/sh
exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
exec /etc/rc.d/alsa start
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/certmaster/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/certmaster/run
index 745b1b3..0b0acd1 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/certmaster/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/certmaster/run
@@ -1,2 +1,5 @@
#!/bin/bash
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
exec /usr/bin/certmaster
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/frontend/log/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/frontend/log/run
index 463045f..df916cd 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/frontend/log/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/frontend/log/run
@@ -1,5 +1,8 @@
#!/bin/sh
exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
. /etc/systemconfig
/usr/bin/logger -p local6.info -t mythfrontend
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run
index 0a398ac..769c229 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/lircd/run
@@ -2,7 +2,6 @@
exec 2>&1
export TERM=linux
-
. /etc/rc.conf
. /etc/rc.d/functions
diff --git a/abs/mv-core/runit-scripts-mv/runitscripts/services/smartd/run b/abs/mv-core/runit-scripts-mv/runitscripts/services/smartd/run
index 15ed769..f3f3bf8 100755
--- a/abs/mv-core/runit-scripts-mv/runitscripts/services/smartd/run
+++ b/abs/mv-core/runit-scripts-mv/runitscripts/services/smartd/run
@@ -1,13 +1,13 @@
#!/bin/bash
-
- . /etc/rc.conf
- . /etc/rc.d/functions
-
- stat_runit "Starting smartd"
- /usr/sbin/smartd -n -c /etc/smartd.conf -q never &>/dev/null
- if [ $? -ne 0 ]; then
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting smartd"
+/usr/sbin/smartd -n -c /etc/smartd.conf -q never &>/dev/null
+if [ $? -ne 0 ]
+then
stat_fail
- else
- add_daemon smartd
- stat_done
- fi
+else
+ add_daemon smartd
+ stat_done
+fi