summaryrefslogtreecommitdiffstats
path: root/abs/mv-core/syslog-ng/syslog.install
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-11-30 04:11:03 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-11-30 04:11:03 (GMT)
commitf78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f (patch)
tree35b4ab3030640a144537124112e3d65d138672f5 /abs/mv-core/syslog-ng/syslog.install
parentfba7ea15ad46f8655bf17ab4c1cc5a8228d39e1b (diff)
parentf0da28db238a7c58552446e2d87bae48a0f9718b (diff)
downloadlinhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.zip
linhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.tar.gz
linhes_pkgbuild-f78fc8e0364cb99bf0b3c2fc941ba85c2fe5944f.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/mv-core/syslog-ng/syslog.install')
-rwxr-xr-xabs/mv-core/syslog-ng/syslog.install56
1 files changed, 56 insertions, 0 deletions
diff --git a/abs/mv-core/syslog-ng/syslog.install b/abs/mv-core/syslog-ng/syslog.install
new file mode 100755
index 0000000..014edbd
--- /dev/null
+++ b/abs/mv-core/syslog-ng/syslog.install
@@ -0,0 +1,56 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+/bin/true
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+ mv /etc/syslog-ng.conf /etc/syslog-ng.conf.old
+
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+if [ -f /etc/systemconfig ]
+then
+. /etc/systemconfig
+. /etc/profile
+#cp /etc/syslog-ng.conf.pacnew /etc/syslog-ng.conf
+COMMAND="%s/^destination d_remote.*$/destination d_remote \{tcp\(\"${dbhost}\" port\(514\)\) \;\} \;/"
+ex /etc/syslog-ng.conf <<EOF
+:$COMMAND
+:wq
+EOF
+fi
+ ln -s /usr/bin/log_care.sh /etc/cron.daily/log_care.sh
+
+/bin/true
+}
+
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*