summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/dash/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/dash/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/dash/PKGBUILD')
-rw-r--r--abs/not_built/core/dash/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/not_built/core/dash/PKGBUILD b/abs/not_built/core/dash/PKGBUILD
new file mode 100644
index 0000000..b4d3c80
--- /dev/null
+++ b/abs/not_built/core/dash/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 81892 2010-06-06 21:30:28Z dan $
+# Maintainer: Dan McGee <dan@archlinux.org>
+
+pkgname=dash
+pkgver=0.5.6.1
+pkgrel=1
+pkgdesc="A POSIX compliant shell that aims to be as small as possible"
+arch=('i686' 'x86_64')
+url="http://gondor.apana.org.au/~herbert/dash/"
+license=('BSD')
+groups=('base')
+depends=('glibc')
+#provides=('sh')
+source=("http://gondor.apana.org.au/~herbert/dash/files/dash-$pkgver.tar.gz")
+md5sums=('1c846f4f5a33c0050b2045a6f7037e56')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --mandir=/usr/share/man --exec-prefix=""
+ make || return 1
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install || return 1
+
+ # license
+ install -m644 -D COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+
+ # dash is our default /bin/sh
+ #cd $pkgdir/bin
+ #ln -s dash sh
+}