summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/feh
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/feh
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/feh')
-rw-r--r--abs/not_built/core/feh/PKGBUILD31
-rw-r--r--abs/not_built/core/feh/__changelog1
2 files changed, 32 insertions, 0 deletions
diff --git a/abs/not_built/core/feh/PKGBUILD b/abs/not_built/core/feh/PKGBUILD
new file mode 100644
index 0000000..0f97b3b
--- /dev/null
+++ b/abs/not_built/core/feh/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 94545 2010-10-08 08:16:45Z bisson $
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=feh
+pkgver=1.10
+pkgrel=2
+pkgdesc='Fast, lightweight image viewer which uses imlib2'
+arch=('i686' 'x86_64')
+url='https://derf.homelinux.org/~derf/projects/feh/'
+license=('MIT')
+depends=('libxinerama' 'giblib' 'perl' 'libjpeg7' 'libpng12')
+makedepends=('libxt')
+source=("https://derf.homelinux.org/~derf/projects/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha1sums=('c42095ed6a7636fe9d1ec90d3994f4a57af84681')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i -e 's:/usr/local:/usr:g' config.mk
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/not_built/core/feh/__changelog b/abs/not_built/core/feh/__changelog
new file mode 100644
index 0000000..431a054
--- /dev/null
+++ b/abs/not_built/core/feh/__changelog
@@ -0,0 +1 @@
+1/20/11 - chw - Added libjpeg7 and libpng12 as deps.