summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/fltk
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/fltk
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/fltk')
-rw-r--r--abs/not_built/core/fltk/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/not_built/core/fltk/PKGBUILD b/abs/not_built/core/fltk/PKGBUILD
new file mode 100644
index 0000000..f5335f6
--- /dev/null
+++ b/abs/not_built/core/fltk/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 71291 2010-03-06 01:40:12Z pierre $
+
+pkgname=fltk
+pkgver=1.1.10
+pkgrel=1
+pkgdesc="Graphical user interface toolkit for X"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://www.fltk.org/"
+depends=('libjpeg' 'libpng' 'gcc-libs' 'libxft' 'libxext')
+makedepends=('mesa')
+source=("http://ftp.easysw.com/pub/$pkgname/$pkgver/$pkgname-$pkgver-source.tar.bz2")
+md5sums=('a1765594bc427ff892e36089fe1fa672')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
+ export LDFLAGS="${LDFLAGS//,--as-needed}"
+ ./configure --prefix=/usr --enable-threads --enable-xft --enable-shared
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}