summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/kdelibs3
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/kdelibs3
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/kdelibs3')
-rw-r--r--abs/not_built/core/kdelibs3/PKGBUILD57
-rw-r--r--abs/not_built/core/kdelibs3/__changelog1
-rwxr-xr-xabs/not_built/core/kdelibs3/kde3.profile15
-rw-r--r--abs/not_built/core/kdelibs3/kdelibs3.install11
4 files changed, 84 insertions, 0 deletions
diff --git a/abs/not_built/core/kdelibs3/PKGBUILD b/abs/not_built/core/kdelibs3/PKGBUILD
new file mode 100644
index 0000000..5331af0
--- /dev/null
+++ b/abs/not_built/core/kdelibs3/PKGBUILD
@@ -0,0 +1,57 @@
+# $ Id: $
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=kdelibs3
+pkgver=3.5.10
+pkgrel=3
+pkgdesc="KDE3 Core Libraries"
+arch=('i686' 'x86_64')
+url="http://www.kde.org"
+license=('GPL' 'LGPL')
+depends=('libxslt' 'pcre' 'libart-lgpl' 'alsa-lib'
+ 'jasper' 'bzip2' 'openssl' 'libidn' 'libxrender'
+ 'aspell' 'heimdal' 'acl' 'libtiff' 'qt3' 'ca-certificates'
+ 'libjpeg')
+makedepends=('pkgconfig' )
+options=('libtool')
+install='kdelibs3.install'
+source=("http://download.kde.org/stable/${pkgver}/src/kdelibs-${pkgver}.tar.bz2"
+ 'kde3.profile')
+md5sums=('43cd55ed15f63b5738d620ef9f9fd568'
+ '3c49828eb8985cfb25af8e1495f7800a')
+
+build() {
+ cd $srcdir/kdelibs-$pkgver
+
+ . /etc/profile.d/qt3.sh
+ . $srcdir/kde3.profile
+
+ # install KDE3 profile
+ install -D -m755 $srcdir/kde3.profile $pkgdir/etc/profile.d/kde3.sh
+
+ ./configure --prefix=/opt/kde \
+ --with-distribution='Arch Linux' \
+ --with-alsa \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --disable-dnssd \
+ --disable-dnotify \
+ --enable-inotify \
+ --enable-sendfile \
+ --without-lua \
+ --without-hspell \
+ --enable-gcc-hidden-visibility \
+ --enable-final \
+ --enable-new-ldflags LDFLAGS="${LDFLAGS} -L/opt/qt/lib" \
+ --without-arts \
+ --disable-cups \
+ --disable-libfam || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+
+ # cert bundle seems to be hardcoded
+ # link it to the one from ca-certificates
+ rm -f $pkgdir/opt/kde/share/apps/kssl/ca-bundle.crt
+ ln -sf /etc/ssl/certs/ca-certificates.crt $pkgdir/opt/kde/share/apps/kssl/ca-bundle.crt
+}
diff --git a/abs/not_built/core/kdelibs3/__changelog b/abs/not_built/core/kdelibs3/__changelog
new file mode 100644
index 0000000..2abf977
--- /dev/null
+++ b/abs/not_built/core/kdelibs3/__changelog
@@ -0,0 +1 @@
+remove cups support
diff --git a/abs/not_built/core/kdelibs3/kde3.profile b/abs/not_built/core/kdelibs3/kde3.profile
new file mode 100755
index 0000000..d7c7e9d
--- /dev/null
+++ b/abs/not_built/core/kdelibs3/kde3.profile
@@ -0,0 +1,15 @@
+export KDE3DIR=/opt/kde
+export KDEDIRS=/usr:$KDE3DIR
+export PATH=$PATH:$KDE3DIR/bin
+export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:$KDE3DIR/lib/pkgconfig
+if [ ! -z $XDG_DATA_DIRS ]; then
+ export XDG_DATA_DIRS=$XDG_DATA_DIRS:$KDE3DIR/share
+else
+ export XDG_DATA_DIRS=$KDE3DIR/share
+fi
+if [ ! -z $XDG_CONFIG_DIRS ]; then
+ export XDG_CONFIG_DIRS=$XDG_CONFIG_DIRS:$KDE3DIR/etc/xdg
+else
+ export XDG_CONFIG_DIRS=$KDE3DIR/etc/xdg
+fi
+unset KDE3DIR \ No newline at end of file
diff --git a/abs/not_built/core/kdelibs3/kdelibs3.install b/abs/not_built/core/kdelibs3/kdelibs3.install
new file mode 100644
index 0000000..060ba21
--- /dev/null
+++ b/abs/not_built/core/kdelibs3/kdelibs3.install
@@ -0,0 +1,11 @@
+post_install() {
+ grep -q '/opt/kde/lib' etc/ld.so.conf || echo '/opt/kde/lib' >> etc/ld.so.conf
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ sed -ie '/\/opt\/kde\/lib/d' etc/ld.so.conf
+}