summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/libsmbios
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/libsmbios
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/libsmbios')
-rw-r--r--abs/not_built/core/libsmbios/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/abs/not_built/core/libsmbios/PKGBUILD b/abs/not_built/core/libsmbios/PKGBUILD
new file mode 100644
index 0000000..c996a28
--- /dev/null
+++ b/abs/not_built/core/libsmbios/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 78087 2010-04-19 09:25:42Z dgriffiths $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+# Contributor: daniel g. siegel <dgsiegel@gmail.com>
+
+pkgname=libsmbios
+pkgver=2.2.16
+pkgrel=2
+pkgdesc="A library for providing access to as much BIOS information as possible"
+arch=('i686' 'x86_64')
+url="http://linux.dell.com/libsmbios/main/index.html"
+license=('GPL' 'custom')
+depends=('gcc-libs>=4.3.3')
+makedepends=('libxml2')
+optdepends=('python: tools')
+source=(http://linux.dell.com/libsmbios/download/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz)
+options=('!libtool')
+md5sums=('6edf6659fbb77e7d0f60d5217a7d88ed')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir build
+ cd build
+ ../configure --prefix=/usr --sysconfdir=/etc --disable-static || return 1
+ mkdir -p out/libsmbios_c
+ mkdir -p out/libsmbios_c++
+ LD_PRELOAD="" make || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/usr/include"
+ cp -a ../src/include/* "${pkgdir}/usr/include/" || return 1
+ cp -a out/public-include/* "${pkgdir}/usr/include/" || return 1
+
+ rm -rf "${pkgdir}/etc/yum"
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 ../COPYING-OSL "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+}