summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/lshw/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/lshw/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/lshw/PKGBUILD')
-rw-r--r--abs/not_built/core/lshw/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/abs/not_built/core/lshw/PKGBUILD b/abs/not_built/core/lshw/PKGBUILD
new file mode 100644
index 0000000..6d76925
--- /dev/null
+++ b/abs/not_built/core/lshw/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 29087 2010-10-10 07:47:30Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Stefano Zamprogno <stefano dot zamprogno at gmail dot com>
+# Contributor: Chuck Yang <Chuck.Yang@gmail.com>
+
+pkgname=lshw
+pkgver=B.02.15
+pkgrel=1
+pkgdesc="A small tool to provide detailed information on the hardware configuration of the machine."
+url="http://ezix.org/project/wiki/HardwareLiSter"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+optdepends=('gtk2')
+makedepends=('gcc')
+source=(http://ezix.org/software/files/lshw-$pkgver.tar.gz
+ abi_stdlib.diff)
+md5sums=('970bd9eb05fa3ae139a24a417465c54c'
+ '7adcdd7a2be2feba956a9832cf36abdf')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+# patch -Np1 -i ../abi_stdlib.diff || return 1
+
+ make || return 1
+ make gui || return 1
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir/ install || return 1
+ make DESTDIR=$pkgdir/ install-gui || return 1
+}
+