summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/mythtv/stable-0.24/mythsmolt
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/mythtv/stable-0.24/mythsmolt
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/mythtv/stable-0.24/mythsmolt')
-rw-r--r--abs/not_built/core/mythtv/stable-0.24/mythsmolt/PKGBUILD23
-rw-r--r--abs/not_built/core/mythtv/stable-0.24/mythsmolt/mythsmolt.patch8
-rw-r--r--abs/not_built/core/mythtv/stable-0.24/mythsmolt/smolt_init_login.sh39
3 files changed, 70 insertions, 0 deletions
diff --git a/abs/not_built/core/mythtv/stable-0.24/mythsmolt/PKGBUILD b/abs/not_built/core/mythtv/stable-0.24/mythsmolt/PKGBUILD
new file mode 100644
index 0000000..c145741
--- /dev/null
+++ b/abs/not_built/core/mythtv/stable-0.24/mythsmolt/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=mythsmolt
+pkgver=0.24
+pkgrel=9
+pkgdesc="mythsmolt, a hardware profileing tool"
+arch=('i686' 'x86_64')
+url="http://www.mythvantage.com"
+license=('GPL')
+depends=("mythtv>=${pkgver}" urlgrabber python-simplejson python-pycurl)
+#source=("http://jmeyer.us/download/mythsmolt.tar.gz" 'smolt_init_login.sh' 'mythsmolt.patch')
+source=("http://jmeyer.us/download/mythsmolt.tar.gz" 'smolt_init_login.sh' )
+
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythsmolt
+# patch -p1 < ../mythsmolt.patch || return 1
+ ./configure.sh
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install
+ install -D -m 755 $srcdir/smolt_init_login.sh $pkgdir/etc/profile.d/smolt_init_login.sh
+}
+md5sums=('17d740c348301ab47ac557ad7402115b'
+ '57a3416d90e59abbd5062436583c17e1')
diff --git a/abs/not_built/core/mythtv/stable-0.24/mythsmolt/mythsmolt.patch b/abs/not_built/core/mythtv/stable-0.24/mythsmolt/mythsmolt.patch
new file mode 100644
index 0000000..4767865
--- /dev/null
+++ b/abs/not_built/core/mythtv/stable-0.24/mythsmolt/mythsmolt.patch
@@ -0,0 +1,8 @@
+diff -ruaN mythsmolt.orig/settings.pro mythsmolt/settings.pro
+--- mythsmolt.orig/settings.pro 2010-01-06 15:49:59.000000000 +0000
++++ mythsmolt/settings.pro 2010-05-28 03:30:59.000000000 +0000
+@@ -1,3 +1,3 @@
+
+-LIBVERSION = 0.24
++LIBVERSION = 0.24
+
diff --git a/abs/not_built/core/mythtv/stable-0.24/mythsmolt/smolt_init_login.sh b/abs/not_built/core/mythtv/stable-0.24/mythsmolt/smolt_init_login.sh
new file mode 100644
index 0000000..0b76305
--- /dev/null
+++ b/abs/not_built/core/mythtv/stable-0.24/mythsmolt/smolt_init_login.sh
@@ -0,0 +1,39 @@
+if [ $UID = 0 -o $UID = 1000 ]
+then
+ INIT=`ps -p 1 -o comm=`
+ if [ x$INIT = xrunit ]
+ then
+ if [[ -f /home/mythtv/.configure && $- = *i* ]]
+ then
+ if [ ! -z "$PS1" ]
+ then
+ if [ $0 = "-bash" ]
+ then
+ if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+ then
+ echo ""
+ echo "####################################################"
+ echo "It appears you have not yet run smolt"
+ echo "Please take the time to submit your hardware profile"
+ echo ""
+ echo "press any key to continue:"
+ echo "####################################################"
+ read a
+ mkdir -p /home/mythtv/.mythtv/MythSmolt
+ chown -R mythtv:users /home/mythtv/.mythtv/MythSmolt
+
+ if [ $UID = 0 ]
+ then
+ su mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py" && su mythtv -c "touch /home/mythtv/.mythtv/MythSmolt/hw-uuid"
+ else
+ /usr/share/mythtv/mythsmolt/scripts/sendProfile.py && touch /home/mythtv/.mythtv/MythSmolt/hw-uuid
+ fi
+ fi
+ fi
+ fi
+ fi
+ fi
+fi
+
+
+