summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/netcfg
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/netcfg
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/netcfg')
-rw-r--r--abs/not_built/core/netcfg/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/not_built/core/netcfg/PKGBUILD b/abs/not_built/core/netcfg/PKGBUILD
new file mode 100644
index 0000000..7e7ea7b
--- /dev/null
+++ b/abs/not_built/core/netcfg/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 126281 2011-06-04 04:21:49Z eric $
+# Maintainer: James Rayner <james@archlinux.org>
+
+pkgname=netcfg
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="Network configuration and profile scripts"
+url="http://archlinux.org"
+license=("BSD")
+backup=(etc/iftab)
+depends=(wireless_tools coreutils "wpa_supplicant>=0.6.8" net-tools "dhcpcd>=4.0" "iproute2")
+optdepends=('dialog: Required for menu based profile selector'
+ 'wpa_actiond: Required for automatic wireless connection with rc.d/net-auto-wireless'
+ 'ifplugd: Required for automatic wired connection with rc.d/net-auto-wired')
+source=(ftp://ftp.archlinux.org/other/netcfg/netcfg-${pkgver}.tar.gz)
+arch=(any)
+md5sums=('6e98bae291eb206d92f9a92bbab8fe80')
+
+package() {
+ cd "$srcdir/netcfg-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/netcfg/LICENSE"
+ ln -s /usr/lib/network/connections/wireless "$pkgdir/usr/lib/network/connections/wireless-dbus"
+ ln -s /usr/bin/netcfg2 "$pkgdir/usr/bin/netcfg"
+}
+