summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/nuvexport/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/nuvexport/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/nuvexport/PKGBUILD')
-rw-r--r--abs/not_built/core/nuvexport/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/core/nuvexport/PKGBUILD b/abs/not_built/core/nuvexport/PKGBUILD
new file mode 100644
index 0000000..27369de
--- /dev/null
+++ b/abs/not_built/core/nuvexport/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Contributor: Paul Mattal <paul@mattal.com>
+# Maintainer: Paul Mattal <paul@archlinux.org>
+pkgname=nuvexport
+pkgver=20080311
+relnum=0.5
+pkgrel=3
+pkgdesc="Export for MythTV nuv files to other formats (DVD/SVCD/DivX,etc.)"
+arch=(i686 x86_64)
+url="http://forevermore.net/files/nuvexport"
+license=""
+depends=(perl perl-dbi 'ffmpeg>=20060920' perl-dbd-mysql perl-date-manip)
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=(http://forevermore.net/files/nuvexport/archive/$pkgname-$relnum-0.$pkgver.svn.tar.bz2 $pkgname-ipod-disable.patch MP4.pm XviD.pm)
+md5sums=('2d0a99623f06394daf3bf8769536d3cd' 'acd2dad9987e68359ead8b0be5e5797c')
+
+build() {
+ cd $startdir/src/$pkgname-$relnum
+
+ sed -i "s|prefix=/usr/local|prefix=$startdir/pkg/usr|g" Makefile || return 1
+ sed -i "s|/usr/bin/install|/bin/install|g" Makefile || return 1
+ sed -i "s|sysconfdir=/etc|sysconfdir=$startdir/pkg/etc|g" Makefile || return 1
+
+ mkdir $startdir/pkg/usr || return 1
+ make install || return 1
+ sed -i "s|/tmp/fifodir|/var/tmp/fifodir|g" $startdir/pkg/usr/share/nuvexport/export/*.pm || return 1
+ cp $startdir/src/MP4.pm $startdir/pkg/usr/share/nuvexport/export/ffmpeg/MP4.pm
+ cp $startdir/src/XviD.pm $startdir/pkg/usr/share/nuvexport/export/ffmpeg/XviD.pm
+}