summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-data-dumper
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/perl_modules/perl-data-dumper
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-data-dumper')
-rw-r--r--abs/not_built/core/perl_modules/perl-data-dumper/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-data-dumper/PKGBUILD b/abs/not_built/core/perl_modules/perl-data-dumper/PKGBUILD
new file mode 100644
index 0000000..6b48a24
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-data-dumper/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Cecil H. Watson <knoppmyth@gmail.com>
+
+pkgname=perl-data-dumper
+_realname=Data-Dumper
+pkgver=2.121
+pkgrel=1
+pkgdesc="Data::Dumper - stringified perl data structures, suitable for both printing and eval."
+arch=(i686 x86_64)
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perlxml' 'perl>=5.10.0')
+options=('!emptydirs')
+source=(ftp://ftp.cpan.org/pub/CPAN/authors/id/I/IL/ILYAM/${_realname}-${pkgver}.tar.gz)
+md5sums=('10d6ff7a85fa3e5f91fcb2e6593cfd1b')
+
+build() {
+ cd ${startdir}/src/${_realname}-${pkgver}
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+
+ find ${startdir}/pkg -name '.packlist' -delete
+ find ${startdir}/pkg -name 'perllocal.pod' -delete
+}