summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-exception-class
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/perl_modules/perl-exception-class
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-exception-class')
-rw-r--r--abs/not_built/core/perl_modules/perl-exception-class/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-exception-class/PKGBUILD b/abs/not_built/core/perl_modules/perl-exception-class/PKGBUILD
new file mode 100644
index 0000000..58e1138
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-exception-class/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: François Charette <firmicus ατ gmx δοτ net>
+
+pkgname=perl-exception-class
+pkgver=1.24
+pkgrel=1
+pkgdesc="Declare exception class hierarchies"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~DROLSKY/Exception-Class"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/D/DR/DROLSKY/Exception-Class-$pkgver.tar.gz)
+md5sums=('b672b63f8e7f3652980f188c2d58840d')
+
+build() {
+ cd $startdir/src/Exception-Class-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}