summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-mime-parser
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/perl_modules/perl-mime-parser
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-mime-parser')
-rw-r--r--abs/not_built/core/perl_modules/perl-mime-parser/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-mime-parser/PKGBUILD b/abs/not_built/core/perl_modules/perl-mime-parser/PKGBUILD
new file mode 100644
index 0000000..c8adc5d
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-mime-parser/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=perl-mime-parser
+pkgver=5.420
+pkgrel=2
+pkgdesc="Perl/CPAN Module MIME::Parser : Parses streams to create MIME entities"
+arch=("i686" "x86_64")
+url="http://search.cpan.org/DSKOLL/MIME-tools"
+license=("GPL" "Artistic")
+source=("http://www.cpan.org/authors/id/D/DS/DSKOLL/MIME-tools-5.420.tar.gz")
+md5sums=("4db6505cc0132c80c5a9cc54f443a21a")
+makedepends=("perl-io-stringy" "perl-mailtools" )
+#depends=("perl-io-stringy" "perl-mail-field" "perl-mail-header" "perl-mail-internet")
+depends=("perl-io-stringy" "perl-mailtools" )
+build() {
+ cd $startdir/src/MIME-tools-5.420
+ eval `perl -V:archname`
+ /usr/bin/perl Makefile.PL \
+ INSTALLARCHLIB=/usr/lib/perl5/current/${archname} \
+ INSTALLSITELIB=/usr/lib/perl5/site_perl/current \
+ INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${archname} || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -exec rm '{}' \; && \
+ /usr/bin/find $startdir/pkg -name 'perllocal.pod' -exec rm '{}' \; && \
+ /usr/bin/find $startdir/pkg -depth -type d -empty -exec rmdir '{}' \;
+}