summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/perl_modules/perl-x-osd
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/perl_modules/perl-x-osd
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/perl_modules/perl-x-osd')
-rw-r--r--abs/not_built/core/perl_modules/perl-x-osd/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/not_built/core/perl_modules/perl-x-osd/PKGBUILD b/abs/not_built/core/perl_modules/perl-x-osd/PKGBUILD
new file mode 100644
index 0000000..771079b
--- /dev/null
+++ b/abs/not_built/core/perl_modules/perl-x-osd/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: 3ED <krzysztof1987 at gmail dot com>
+#
+pkgname='perl-x-osd'
+_lastauthor="G/GO/GOZER"
+_pkgname='X-Osd'
+pkgver='0.7'
+pkgrel='2'
+pkgdesc="Perl extension to the X On Screen Display library (xosd)"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl' 'xosd')
+url='http://search.cpan.org/dist/X-Osd/'
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('e3bafe11cd51ad9b1e3d1df18516f9bb1ba462f981483b922f2b627b08190391')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ export PERL_MM_USE_DEFAULT=1
+ export PERL_AUTOINSTALL='--skipdeps'
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
+}