summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/python_modules/pyusb
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/python_modules/pyusb
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/python_modules/pyusb')
-rw-r--r--abs/not_built/core/python_modules/pyusb/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/abs/not_built/core/python_modules/pyusb/PKGBUILD b/abs/not_built/core/python_modules/pyusb/PKGBUILD
new file mode 100644
index 0000000..d9349ec
--- /dev/null
+++ b/abs/not_built/core/python_modules/pyusb/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: Jason Giangrande <jgiangrande@clarku.edu>
+pkgname=pyusb
+pkgver=0.4.3
+pkgrel=4
+pkgdesc="A native Python module written in C which provides USB access."
+arch=('i686' 'x86_64')
+url="http://pyusb.berlios.de/"
+license=('GPL')
+depends=('python2' 'libusb')
+makedepends=('setuptools')
+source=(http://downloads.sourceforge.net/project/pyusb/PyUSB%200.x/$pkgver/pyusb-$pkgver.tar.gz)
+md5sums=('a1a43bc6407caccbc22073c56439aa06')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install -f --root="${pkgdir}" || return 1
+}
+