summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/speex
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/speex
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/speex')
-rw-r--r--abs/not_built/core/speex/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/not_built/core/speex/PKGBUILD b/abs/not_built/core/speex/PKGBUILD
new file mode 100644
index 0000000..7bf7e7b
--- /dev/null
+++ b/abs/not_built/core/speex/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 137583 2011-09-09 22:58:20Z allan $
+# Maintainer:
+# Contributer: Jason Chu <jason@archlinux.org>
+
+pkgname=speex
+pkgver=1.2rc1
+pkgrel=2
+pkgdesc="A free codec for free speech"
+arch=('i686' 'x86_64')
+url="http://www.speex.org/"
+license=('BSD')
+depends=('libogg')
+options=('!libtool')
+source=(http://downloads.us.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('c4438b22c08e5811ff10e2b06ee9b9ae')
+
+build() {
+ cd $srcdir/speex-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $srcdir/speex-$pkgver
+ make DESTDIR=$startdir/pkg install
+
+ install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
+}