summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/tiacx
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/tiacx
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/tiacx')
-rw-r--r--abs/not_built/core/tiacx/PKGBUILD41
-rw-r--r--abs/not_built/core/tiacx/acx.install19
-rw-r--r--abs/not_built/core/tiacx/kernel-2.6.27.patch82
-rw-r--r--abs/not_built/core/tiacx/kernel-2.6.30.patch16
-rw-r--r--abs/not_built/core/tiacx/kernel-2.6.31.patch88
-rw-r--r--abs/not_built/core/tiacx/kernel-2.6.33.patch11
6 files changed, 257 insertions, 0 deletions
diff --git a/abs/not_built/core/tiacx/PKGBUILD b/abs/not_built/core/tiacx/PKGBUILD
new file mode 100644
index 0000000..428d993
--- /dev/null
+++ b/abs/not_built/core/tiacx/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: James Rayner <iphitus@gmail.com>
+
+pkgname=tiacx
+pkgver=20080210
+pkgrel=22
+pkgdesc="OpenSource module for Texas Instruments ACX100/ACX111 wireless chips. For stock arch 2.6 kernel"
+arch=(i686 x86_64)
+url="http://acx100.sourceforge.net/"
+license=('MPL')
+depends=('wireless_tools' 'kernel26>=2.6.39' 'kernel26<2.6.40' 'tiacx-firmware')
+makedepends=('kernel26-headers>=2.6.39' 'kernel26-headers<2.6.40')
+install=acx.install
+source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2
+ kernel-2.6.27.patch
+ kernel-2.6.30.patch
+ kernel-2.6.31.patch
+ kernel-2.6.33.patch)
+options=(!strip)
+_kernver=2.6.39-LinHES
+md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12'
+ '9895f72f8d0c84956b0f6c3b16df0fe8'
+ 'e2900aee839ce711a7f7606b3e3de36e'
+ 'dbcb276d77df7801cef58a85c18dfe94'
+ '9cd35ea33b8abdd2e4efec485b05477e')
+
+build() {
+ cd $srcdir/acx-$pkgver
+ patch -Np1 -i ../kernel-2.6.27.patch
+ patch -Np0 -i ../kernel-2.6.30.patch
+ patch -Np1 -i ../kernel-2.6.31.patch
+ patch -Np0 -i ../kernel-2.6.33.patch
+ make -C /lib/modules/${_kernver}/build M=$(pwd)
+}
+
+package () {
+ cd $srcdir/acx-$pkgver
+ install -D acx.ko $pkgdir/lib/modules/${_kernver}/kernel/drivers/net/wireless/tiacx/acx.ko
+ sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/*.install
+ # gzip -9 modules
+ find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
+}
diff --git a/abs/not_built/core/tiacx/acx.install b/abs/not_built/core/tiacx/acx.install
new file mode 100644
index 0000000..971bf32
--- /dev/null
+++ b/abs/not_built/core/tiacx/acx.install
@@ -0,0 +1,19 @@
+# arg 1: the new package version
+post_install() {
+ KERNEL_VERSION='2.6.39-LinHES'
+ depmod $KERNEL_VERSION > /dev/null 2>&1
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ KERNEL_VERSION='2.6.39-LinHES'
+ depmod $KERNEL_VERSION > /dev/null 2>&1
+
+}
+
+# arg 1: the old package version
+post_remove() {
+ KERNEL_VERSION='2.6.39-LinHES'
+ depmod $KERNEL_VERSION > /dev/null 2>&1
+}
diff --git a/abs/not_built/core/tiacx/kernel-2.6.27.patch b/abs/not_built/core/tiacx/kernel-2.6.27.patch
new file mode 100644
index 0000000..f0c114b
--- /dev/null
+++ b/abs/not_built/core/tiacx/kernel-2.6.27.patch
@@ -0,0 +1,82 @@
+diff -Nur acx-20080210.orig/ioctl.c acx-20080210/ioctl.c
+--- acx-20080210.orig/ioctl.c 2008-02-10 21:06:42.000000000 +0100
++++ acx-20080210/ioctl.c 2008-10-10 17:07:32.000000000 +0200
+@@ -489,6 +489,7 @@
+ static char*
+ acx_s_scan_add_station(
+ acx_device_t *adev,
++ struct iw_request_info *info,
+ char *ptr,
+ char *end_buf,
+ struct client *bss)
+@@ -503,14 +504,14 @@
+ iwe.u.ap_addr.sa_family = ARPHRD_ETHER;
+ MAC_COPY(iwe.u.ap_addr.sa_data, bss->bssid);
+ acxlog_mac(L_IOCTL, "scan, station address: ", bss->bssid, "\n");
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_ADDR_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_ADDR_LEN);
+
+ /* Add ESSID */
+ iwe.cmd = SIOCGIWESSID;
+ iwe.u.data.length = bss->essid_len;
+ iwe.u.data.flags = 1;
+ log(L_IOCTL, "scan, essid: %s\n", bss->essid);
+- ptr = iwe_stream_add_point(ptr, end_buf, &iwe, bss->essid);
++ ptr = iwe_stream_add_point(info, ptr, end_buf, &iwe, bss->essid);
+
+ /* Add mode */
+ iwe.cmd = SIOCGIWMODE;
+@@ -520,7 +521,7 @@
+ else
+ iwe.u.mode = IW_MODE_ADHOC;
+ log(L_IOCTL, "scan, mode: %d\n", iwe.u.mode);
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_UINT_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_UINT_LEN);
+ }
+
+ /* Add frequency */
+@@ -528,7 +529,7 @@
+ iwe.u.freq.m = acx_channel_freq[bss->channel - 1] * 100000;
+ iwe.u.freq.e = 1;
+ log(L_IOCTL, "scan, frequency: %d\n", iwe.u.freq.m);
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_FREQ_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_FREQ_LEN);
+
+ /* Add link quality */
+ iwe.cmd = IWEVQUAL;
+@@ -546,7 +547,7 @@
+ iwe.u.qual.updated = 7;
+ log(L_IOCTL, "scan, link quality: %d/%d/%d\n",
+ iwe.u.qual.level, iwe.u.qual.noise, iwe.u.qual.qual);
+- ptr = iwe_stream_add_event(ptr, end_buf, &iwe, IW_EV_QUAL_LEN);
++ ptr = iwe_stream_add_event(info, ptr, end_buf, &iwe, IW_EV_QUAL_LEN);
+
+ /* Add encryption */
+ iwe.cmd = SIOCGIWENCODE;
+@@ -556,7 +557,7 @@
+ iwe.u.data.flags = IW_ENCODE_DISABLED;
+ iwe.u.data.length = 0;
+ log(L_IOCTL, "scan, encryption flags: %X\n", iwe.u.data.flags);
+- ptr = iwe_stream_add_point(ptr, end_buf, &iwe, bss->essid);
++ ptr = iwe_stream_add_point(info, ptr, end_buf, &iwe, bss->essid);
+
+ /* add rates */
+ iwe.cmd = SIOCGIWRATE;
+@@ -570,7 +571,7 @@
+ if (rate & 1) {
+ iwe.u.bitrate.value = *p * 500000; /* units of 500kb/s */
+ log(L_IOCTL, "scan, rate: %d\n", iwe.u.bitrate.value);
+- ptr_rate = iwe_stream_add_value(ptr, ptr_rate, end_buf,
++ ptr_rate = iwe_stream_add_value(info, ptr, ptr_rate, end_buf,
+ &iwe, IW_EV_PARAM_LEN);
+ }
+ rate >>= 1;
+@@ -625,7 +626,7 @@
+ for (i = 0; i < ARRAY_SIZE(adev->sta_list); i++) {
+ struct client *bss = &adev->sta_list[i];
+ if (!bss->used) continue;
+- ptr = acx_s_scan_add_station(adev, ptr,
++ ptr = acx_s_scan_add_station(adev, info, ptr,
+ extra + IW_SCAN_MAX_DATA, bss);
+ }
+ dwrq->length = ptr - extra;
diff --git a/abs/not_built/core/tiacx/kernel-2.6.30.patch b/abs/not_built/core/tiacx/kernel-2.6.30.patch
new file mode 100644
index 0000000..b5d94a1
--- /dev/null
+++ b/abs/not_built/core/tiacx/kernel-2.6.30.patch
@@ -0,0 +1,16 @@
+--- wlan_compat.h~ 2009-06-12 09:17:30.000000000 +0200
++++ wlan_compat.h 2009-06-12 09:17:30.000000000 +0200
+@@ -217,13 +217,6 @@
+ /*=============================================================*/
+ #define WLAN_PACKED __attribute__ ((packed))
+
+-/* Interrupt handler backwards compatibility stuff */
+-#ifndef IRQ_NONE
+-#define IRQ_NONE
+-#define IRQ_HANDLED
+-typedef void irqreturn_t;
+-#endif
+-
+ #ifndef ARPHRD_IEEE80211_PRISM
+ #define ARPHRD_IEEE80211_PRISM 802
+ #endif
diff --git a/abs/not_built/core/tiacx/kernel-2.6.31.patch b/abs/not_built/core/tiacx/kernel-2.6.31.patch
new file mode 100644
index 0000000..2a89e3c
--- /dev/null
+++ b/abs/not_built/core/tiacx/kernel-2.6.31.patch
@@ -0,0 +1,88 @@
+--- acx-20080210/pci.c 2008-02-10 21:06:42.000000000 +0100
++++ acx-20080210/pci.c 2009-09-11 22:27:28.000000000 +0200
+@@ -1437,6 +1437,19 @@
+
+ static void dummy_netdev_init(struct net_device *ndev) {}
+
++static const struct net_device_ops acx_netdev_ops = {
++ .ndo_open = &acxpci_e_open,
++ .ndo_stop = &acxpci_e_close,
++ .ndo_start_xmit = &acx_i_start_xmit,
++ .ndo_get_stats = &acx_e_get_stats,
++#if IW_HANDLER_VERSION <= 5
++ .ndo_get_wireless_stats = &acx_e_get_wireless_stats,
++#endif
++ .ndo_set_multicast_list = &acxpci_i_set_multicast_list,
++ .ndo_tx_timeout = &acxpci_i_tx_timeout,
++ .ndo_change_mtu = &acx_e_change_mtu,
++};
++
+ #ifdef CONFIG_PCI
+ static int __devinit acxpci_e_probe(struct pci_dev *pdev, const struct pci_device_id *id)
+ {
+@@ -1547,17 +1560,8 @@
+ }
+
+ ether_setup(ndev);
+- ndev->open = &acxpci_e_open;
+- ndev->stop = &acxpci_e_close;
+- ndev->hard_start_xmit = &acx_i_start_xmit;
+- ndev->get_stats = &acx_e_get_stats;
+-#if IW_HANDLER_VERSION <= 5
+- ndev->get_wireless_stats = &acx_e_get_wireless_stats;
+-#endif
+- ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
+- ndev->set_multicast_list = &acxpci_i_set_multicast_list;
+- ndev->tx_timeout = &acxpci_i_tx_timeout;
+- ndev->change_mtu = &acx_e_change_mtu;
++ ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
++ ndev->netdev_ops = &acx_netdev_ops;
+ ndev->watchdog_timeo = 4 * HZ;
+ ndev->irq = pdev->irq;
+ ndev->base_addr = pci_resource_start(pdev, 0);
+--- acx-20080210/usb.c 2008-02-10 21:06:42.000000000 +0100
++++ acx-20080210/usb.c 2009-09-11 22:38:42.000000000 +0200
+@@ -778,6 +778,21 @@
+ static void
+ dummy_netdev_init(struct net_device *ndev) {}
+
++static const struct net_device_ops acxusb_netdev_ops = {
++ .ndo_open = &acxusb_e_open,
++ .ndo_stop = &acxusb_e_close,
++ .ndo_start_xmit = (void *)&acx_i_start_xmit,
++ .ndo_get_stats = (void *)&acx_e_get_stats,
++#if IW_HANDLER_VERSION <= 5
++ .ndo_get_wireless_stats = (void *)&acx_e_get_wireless_stats,
++#endif
++ .ndo_set_multicast_list = (void *)&acxusb_i_set_rx_mode,
++#ifdef HAVE_TX_TIMEOUT
++ .ndo_tx_timeout = &acxusb_i_tx_timeout,
++#endif
++ .ndo_change_mtu = &acx_e_change_mtu,
++};
++
+ static int
+ acxusb_e_probe(struct usb_interface *intf, const struct usb_device_id *devID)
+ {
+@@ -845,20 +860,11 @@
+ /* Register the callbacks for the network device functions */
+
+ ether_setup(ndev);
+- ndev->open = &acxusb_e_open;
+- ndev->stop = &acxusb_e_close;
+- ndev->hard_start_xmit = (void *)&acx_i_start_xmit;
+- ndev->get_stats = (void *)&acx_e_get_stats;
+-#if IW_HANDLER_VERSION <= 5
+- ndev->get_wireless_stats = (void *)&acx_e_get_wireless_stats;
+-#endif
+ ndev->wireless_handlers = (struct iw_handler_def *)&acx_ioctl_handler_def;
+- ndev->set_multicast_list = (void *)&acxusb_i_set_rx_mode;
++ ndev->netdev_ops = &acxusb_netdev_ops;
+ #ifdef HAVE_TX_TIMEOUT
+- ndev->tx_timeout = &acxusb_i_tx_timeout;
+ ndev->watchdog_timeo = 4 * HZ;
+ #endif
+- ndev->change_mtu = &acx_e_change_mtu;
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)) && defined(SET_MODULE_OWNER)
+ SET_MODULE_OWNER(ndev);
+ #endif
diff --git a/abs/not_built/core/tiacx/kernel-2.6.33.patch b/abs/not_built/core/tiacx/kernel-2.6.33.patch
new file mode 100644
index 0000000..f486009
--- /dev/null
+++ b/abs/not_built/core/tiacx/kernel-2.6.33.patch
@@ -0,0 +1,11 @@
+--- pci.c~ 2010-02-27 19:30:54.000000000 +0100
++++ pci.c 2010-02-27 19:30:54.000000000 +0100
+@@ -35,7 +35,7 @@
+
+ /* Linux 2.6.18+ uses <linux/utsrelease.h> */
+ #ifndef UTS_RELEASE
+-#include <linux/utsrelease.h>
++#include <generated/utsrelease.h>
+ #endif
+
+ #include <linux/compiler.h> /* required for Lx 2.6.8 ?? */