summaryrefslogtreecommitdiffstats
path: root/abs/not_built/core/tweaker/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/core/tweaker/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/core/tweaker/PKGBUILD')
-rw-r--r--abs/not_built/core/tweaker/PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/abs/not_built/core/tweaker/PKGBUILD b/abs/not_built/core/tweaker/PKGBUILD
new file mode 100644
index 0000000..85df000
--- /dev/null
+++ b/abs/not_built/core/tweaker/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=tweaker
+pkgver=1
+pkgrel=56
+pkgdesc="applies tweaks to the baseline configuration and attempts to optimize settings for the hardware it finds"
+arch=('i686' 'x86_64')
+
+depends=('bash' 'perl' 'perl-dbi' 'perl-exception-class' 'perl-log-log4perl' 'perl-log-dispatch' 'perl-getopt-lucid' 'perl-list-member' 'perl-class-data-inheritable' 'perl-devel-stacktrace' 'perl-xml-twig')
+
+source=(tweaker.sh log4perl.conf)
+
+license=('GPL2')
+#groups=('pvr')
+
+
+install=tweaker.install
+build() {
+ TWEAKER_ROOT=usr/LH/tweaker
+ mkdir -p $startdir/pkg/$TWEAKER_ROOT
+ mkdir -p $startdir/pkg/$TWEAKER_ROOT/{bin,fs,tcf}
+ mkdir -p $startdir/pkg/etc/profile.d
+ mkdir -p $startdir/pkg/usr/lib/perl5/vendor_perl/Tweaker/
+
+ cd $startdir
+ # executables
+ install -m0777 -D bin/* $startdir/pkg/$TWEAKER_ROOT/bin
+
+ # parallel root directory structure used for seeding configuration files
+ # Ensure shell variables are configured at start; ensure $TWEAKER_ROOT/bin is in $PATH
+ cp -rp fs $startdir/pkg/$TWEAKER_ROOT/
+ chmod -R 0777 $startdir/pkg/$TWEAKER_ROOT/
+
+ # Tweaker configuration files
+ install -m0555 -D tcf/* $startdir/pkg/$TWEAKER_ROOT/tcf
+
+ # Tweaker-centric log4perl configuration
+ #install -m0755 log4perl.conf $startdir/pkg/etc/log4perl.conf
+ install -m0755 log4perl.conf $startdir/pkg/$TWEAKER_ROOT
+
+ install -m0755 tweaker.sh $startdir/pkg/etc/profile.d/tweaker.sh
+
+ # Copy our tweaker Perl modules for general use
+ install -m0555 lib/Tweaker/* $startdir/pkg/usr/lib/perl5/vendor_perl/Tweaker/
+}
+md5sums=('77fab526e866b273091e6816135ef25f'
+ 'e897b87dd308f9562d0867de9fab2de0')