summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/alsa-driver
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/alsa-driver
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/alsa-driver')
-rw-r--r--abs/not_built/extra/alsa-driver/PKGBUILD25
-rw-r--r--abs/not_built/extra/alsa-driver/alsa-driver.install8
2 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/extra/alsa-driver/PKGBUILD b/abs/not_built/extra/alsa-driver/PKGBUILD
new file mode 100644
index 0000000..c4c3624
--- /dev/null
+++ b/abs/not_built/extra/alsa-driver/PKGBUILD
@@ -0,0 +1,25 @@
+# Syco <SycoLTH at gmail dot com>
+
+pkgname=alsa-driver
+_pkgname=alsa-driver
+pkgver=1.0.24
+pkgrel=0
+pkgdesc="An alternative implementation of Linux sound support"
+arch=('i686' 'x86_64')
+provides=(alsa-driver)
+install='alsa-driver.install'
+url="http://www.alsa-project.org"
+license=('GPL')
+options=(!libtool)
+#source=(ftp://ftp.alsa-project.org/pub/driver/${_pkgname}-${pkgver}.tar.bz2)
+source=(http://mirrors.zerg.biz/alsa/driver/${_pkgname}-${pkgver}.tar.bz2)
+md5sums=('a4ffd80745ce5098dfd48d83c2769e0e')
+
+build() {
+ k_updates=${pkgdir}/lib/modules/$(uname -r)/updates
+ install -d ${k_updates}
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ ./configure --with-cards=all
+ make || return 1
+ install -D -m644 modules/*.ko ${k_updates} || return 1
+}
diff --git a/abs/not_built/extra/alsa-driver/alsa-driver.install b/abs/not_built/extra/alsa-driver/alsa-driver.install
new file mode 100644
index 0000000..912055c
--- /dev/null
+++ b/abs/not_built/extra/alsa-driver/alsa-driver.install
@@ -0,0 +1,8 @@
+_kernver=`uname -r`
+ post_remove() {
+ depmod -a $_kernver
+}
+
+post_install() {
+ depmod -a $_kernver
+}