summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/cabextract/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/cabextract/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/cabextract/PKGBUILD')
-rw-r--r--abs/not_built/extra/cabextract/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/not_built/extra/cabextract/PKGBUILD b/abs/not_built/extra/cabextract/PKGBUILD
new file mode 100644
index 0000000..4e7b2cf
--- /dev/null
+++ b/abs/not_built/extra/cabextract/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 86106 2010-07-25 21:30:58Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+
+pkgname=cabextract
+pkgver=1.3
+pkgrel=1
+pkgdesc="A program to extract Microsoft cabinet (.CAB) files."
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.cabextract.org.uk/"
+depends=('glibc')
+source=(http://www.cabextract.org.uk/${pkgname}-${pkgver}.tar.gz)
+md5sums=('cb9a4a38470d2a71a0275968e7eb64d3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}