summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/celt-0.7
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/celt-0.7
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/celt-0.7')
-rw-r--r--abs/not_built/extra/celt-0.7/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/not_built/extra/celt-0.7/PKGBUILD b/abs/not_built/extra/celt-0.7/PKGBUILD
new file mode 100644
index 0000000..59b9e9c
--- /dev/null
+++ b/abs/not_built/extra/celt-0.7/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Lauri Niskanen <ape@ape3000.com>
+
+pkgname=celt-0.7
+_realname=celt
+pkgver=0.7.1
+pkgrel=2
+pkgdesc="Low-latency audio communication codec"
+arch=('i686' 'x86_64')
+url="http://www.celt-codec.org"
+license=('BSD')
+depends=('libogg')
+provides=('celt=$pkgver')
+conflicts=('celt')
+options=('!libtool')
+source=(http://downloads.xiph.org/releases/celt/$_realname-$pkgver.tar.gz)
+md5sums=('c7f6b8346e132b1a48dae0eff77ea9f0')
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+ make DESTDIR="$pkgdir/" install
+}
+
+package() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ install -Dm644 COPYING \
+ "$pkgdir/usr/share/licenses/$pkgname/BSD"
+}
+
+# vim:set ts=2 sw=2 et: