summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/djmount
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/community/djmount
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/community/djmount')
-rw-r--r--abs/not_built/extra/community/djmount/PKGBUILD25
-rw-r--r--abs/not_built/extra/community/djmount/djmount.confd2
-rwxr-xr-xabs/not_built/extra/community/djmount/djmount.rcd39
3 files changed, 66 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/djmount/PKGBUILD b/abs/not_built/extra/community/djmount/PKGBUILD
new file mode 100644
index 0000000..a3648dc
--- /dev/null
+++ b/abs/not_built/extra/community/djmount/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Michele Schäuble <mschaeuble@swissonline.ch>
+
+pkgname=djmount
+pkgver=0.71
+pkgrel=1
+pkgdesc="A UPnP AV client that mounts media server contents as a filesystem."
+arch=('i686')
+url="http://djmount.sourceforge.net/"
+license=('GPL')
+depends=('fuse')
+source=(http://voxel.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz \
+ djmount.rcd djmount.confd)
+md5sums=('c922753e706c194bf82a8b6ca77e6a9a' \
+ 'f473b5150df385447f2f58049bfb6199' \
+ '21de4c947c17e8558f1007a20757f254')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+
+ install -D -m755 $startdir/src/djmount.rcd $startdir/pkg/etc/rc.d/djmount
+ install -D -m644 $startdir/src/djmount.confd $startdir/pkg/etc/conf.d/djmount
+}
diff --git a/abs/not_built/extra/community/djmount/djmount.confd b/abs/not_built/extra/community/djmount/djmount.confd
new file mode 100644
index 0000000..079100e
--- /dev/null
+++ b/abs/not_built/extra/community/djmount/djmount.confd
@@ -0,0 +1,2 @@
+OPTIONS="-o ro,allow_other"
+MOUNTPOINT="/media/upnp"
diff --git a/abs/not_built/extra/community/djmount/djmount.rcd b/abs/not_built/extra/community/djmount/djmount.rcd
new file mode 100755
index 0000000..84899dd
--- /dev/null
+++ b/abs/not_built/extra/community/djmount/djmount.rcd
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+ . /etc/rc.conf
+ . /etc/rc.d/functions
+
+# source application-specific settings
+[ -f /etc/conf.d/djmount ] && . /etc/conf.d/djmount
+
+ case "$1" in
+
+ start)
+ stat_busy "Starting djmount"
+ /usr/bin/djmount $OPTIONS $MOUNTPOINT &>/dev/null
+ if [ $? -ne 0 ]; then
+ stat_fail
+ else
+ add_daemon djmount
+ stat_done
+ fi
+ ;;
+
+ stop)
+ stat_busy "Stopping djmount"
+ fusermount -u $MOUNTPOINT
+ kill -9 `pidof /usr/bin/djmount` &>/dev/null
+ rm_daemon djmount
+ stat_done
+ ;;
+
+ restart)
+ stat_busy "Restarting djmount ..."
+ $0 stop
+ $0 start
+ stat_done
+ ;;
+
+ *)
+ echo "usage: $0 {start|stop|restart}"
+ esac