summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/nvclock/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/community/nvclock/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/community/nvclock/PKGBUILD')
-rw-r--r--abs/not_built/extra/community/nvclock/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/nvclock/PKGBUILD b/abs/not_built/extra/community/nvclock/PKGBUILD
new file mode 100644
index 0000000..d49f915
--- /dev/null
+++ b/abs/not_built/extra/community/nvclock/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 23406 2009-01-09 22:39:57Z andyrtr $
+# Contributor: Markus Meissner <markus@meissna.de>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=nvclock
+pkgver=0.8b4
+pkgrel=1
+pkgdesc="A small utility which allows users to overclock NVIDIA based video cards"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gtk2')
+source=(http://www.linuxhardware.org/$pkgname/${pkgname}${pkgver}.tar.gz
+ nvclock-0.8b4-buildfix.patch)
+url="http://www.linuxhardware.org/nvclock/"
+md5sums=('23f1b3ebf40f35d76d5fdac50f66ab11'
+ '1da24b50dd6a8c4704fa550a3e1a8b53')
+options=('!makeflags')
+
+build(){
+ cd ${srcdir}/$pkgname$pkgver
+ # build fix from Fedora
+ patch -Np1 -i $srcdir/nvclock-0.8b4-buildfix.patch || return 1
+ sed -i 's:${prefix}/man:${prefix}\/share\/man:' ${srcdir}/$pkgname$pkgver/Makefile.in || return 1
+ ./configure --prefix=/usr --bindir=/usr/bin
+ make || return 1 || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}