summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/tre
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/community/tre
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/community/tre')
-rw-r--r--abs/not_built/extra/community/tre/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/tre/PKGBUILD b/abs/not_built/extra/community/tre/PKGBUILD
new file mode 100644
index 0000000..52fb147
--- /dev/null
+++ b/abs/not_built/extra/community/tre/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Igor Galic<i.galic@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de
+pkgname=tre
+pkgver=0.8.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="POSIX compliant regexp matching library. Includes agrep for aproximate grepping."
+url="http://laurikari.net/tre/index.html"
+depends=('glibc')
+license=('custom:BSD')
+source=(http://laurikari.net/tre/$pkgname-$pkgver.tar.bz2)
+md5sums=('b4d3232593dadf6746f4727bdda20b41')
+options=('!libtool')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+ ./configure --prefix=/usr --enable-static || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ install -Dm644 ${srcdir}/$pkgname-$pkgver/LICENSE \
+ ${pkgdir}/usr/share/licenses/$pkgname/LICENSE || return 1
+ install -d ${pkgdir}/usr/share/doc/$pkgname
+ cd doc
+ for _i in default.css tre-api.html tre-syntax.html
+ do
+ install -Dm644 ${_i} ${pkgdir}/usr/share/doc/$pkgname/${_i}
+ done || return 1
+}