summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/community/video4fuze/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/community/video4fuze/PKGBUILD
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/community/video4fuze/PKGBUILD')
-rw-r--r--abs/not_built/extra/community/video4fuze/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/not_built/extra/community/video4fuze/PKGBUILD b/abs/not_built/extra/community/video4fuze/PKGBUILD
new file mode 100644
index 0000000..35c1e85
--- /dev/null
+++ b/abs/not_built/extra/community/video4fuze/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Michael Hanson <hansonorders@verizon.net>
+# Maintainer: Michael Hanson <hansonorders@verizon.net>
+pkgname=video4fuze
+pkgver=0.6
+pkgrel=1
+pkgdesc="A tool to make videos compatable with the San Disk Sana Fuze media player"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/video4fuze"
+license=('GPL3' 'CC-BY-SA-3.0')
+depends=('fuzemux' 'python2>=2.5' 'qt>=4.5' 'pyqt>=4.5' 'python-imaging' 'mplayer' 'ffmpeg-svn')
+optdepends=('xterm')
+source=("http://${pkgname}.googlecode.com/files/${pkgname}-${pkgver}%2B.tar.gz")
+provides=('video4fuze')
+replaces=('video4fuze-svn')
+install=video4fuze.install
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}+
+
+ for file in GUI/*.py *.py *.pyw ; do
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' ${file}
+ done
+
+ sed -i 's/^python/python2/g' dist/*
+
+ lrelease video4fuze_e4x.pro
+
+ python2 setup.py install --root="$pkgdir" || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}+
+ install -D -m644 README.txt ${pkgdir}/usr/share/doc/video4fuze/README || return 1
+ chmod 755 ${pkgdir}/usr/share/video4fuze/*.py || return 1
+ chmod 755 ${pkgdir}/usr/share/video4fuze/*.pyw || return 1
+ chmod 755 ${pkgdir}/usr/share/video4fuze/GUI/*.py || return 1
+}
+md5sums=('f19250f2e166e10e5b115e8bffdfee35')