summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/crypto++
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/crypto++
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/crypto++')
-rw-r--r--abs/not_built/extra/crypto++/PKGBUILD36
-rw-r--r--abs/not_built/extra/crypto++/libcrypto++.pc11
2 files changed, 47 insertions, 0 deletions
diff --git a/abs/not_built/extra/crypto++/PKGBUILD b/abs/not_built/extra/crypto++/PKGBUILD
new file mode 100644
index 0000000..45c90d5
--- /dev/null
+++ b/abs/not_built/extra/crypto++/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id$
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Kritoke <kritoke@gamebox.net>
+# Contributor: jlvsimoes <jlvsimoes@oninet.pt>
+
+pkgname=crypto++
+pkgver=5.6.1
+_srcver=561
+pkgrel=2
+pkgdesc="A free C++ class library of cryptographic schemes."
+arch=('i686' 'x86_64')
+url="http://www.cryptopp.com/"
+license=('custom')
+depends=('gcc-libs')
+makedepends=('unzip')
+source=(http://www.cryptopp.com/cryptopp${_srcver}.zip
+ libcrypto++.pc)
+md5sums=('96cbeba0907562b077e26bcffb483828'
+ '2337c6edbc552d9142cae8e0854715e7')
+
+build() {
+ cd ${srcdir}
+ sed -i -e 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
+ export CXXFLAGS="${CXXFLAGS} -DNDEBUG -fPIC"
+ make -f GNUmakefile
+ make libcryptopp.so
+ install -d ${pkgdir}/usr/{lib/pkgconfig,include/cryptopp}
+ install -m644 *.h ${pkgdir}/usr/include/cryptopp/
+ install -m644 libcryptopp.a ${pkgdir}/usr/lib/libcryptopp.a
+ install -m644 libcryptopp.so ${pkgdir}/usr/lib/libcryptopp.so
+ install -m644 ${srcdir}/libcrypto++.pc "${pkgdir}/usr/lib/pkgconfig/libcrypto++.pc"
+ install -D -m644 License.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
diff --git a/abs/not_built/extra/crypto++/libcrypto++.pc b/abs/not_built/extra/crypto++/libcrypto++.pc
new file mode 100644
index 0000000..698d761
--- /dev/null
+++ b/abs/not_built/extra/crypto++/libcrypto++.pc
@@ -0,0 +1,11 @@
+# Written by Alexander Rødseth <rodseth@gmail.com>
+
+prefix=/usr
+libdir=${prefix}/lib
+includedir=${prefix}/include
+
+Name: libcrypto++-5.6.1
+Description: Class library of cryptographic schemes
+Version: 5.6.1
+Libs: -L${libdir} -lcryptopp
+Cflags: -I${includedir}