summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/crystalhd-git
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/crystalhd-git
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/crystalhd-git')
-rw-r--r--abs/not_built/extra/crystalhd-git/PKGBUILD52
-rw-r--r--abs/not_built/extra/crystalhd-git/crystalhd-git.install6
2 files changed, 58 insertions, 0 deletions
diff --git a/abs/not_built/extra/crystalhd-git/PKGBUILD b/abs/not_built/extra/crystalhd-git/PKGBUILD
new file mode 100644
index 0000000..a7b3e7f
--- /dev/null
+++ b/abs/not_built/extra/crystalhd-git/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Petteri Tolonen <petteri.tolonen[at]gmail.com>
+# Maintainer: Petteri Tolonen <petteri.tolonen[at]gmail.com>
+
+pkgname=crystalhd-git
+pkgver=20111227
+pkgrel=1
+pkgdesc="Broadcom CrystalHD kernel module"
+arch=('i686' 'x86_64')
+url="http://linuxtv.org/git/jarod/crystalhd.git"
+license=('GPL2')
+depends=('libcrystalhd-git')
+makedepends=('autoconf' 'make' 'git')
+install='crystalhd-git.install'
+conflicts=('crystalhd')
+_gitroot='git://linuxtv.org/jarod/crystalhd.git'
+_gitname='crystalhd'
+
+build() {
+
+ cd $startdir/src
+
+ msg "Connecting to the GIT server...."
+
+ if [ -d $startdir/src/$_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot
+ cd $_gitname
+ fi
+
+ cd driver/linux
+
+ autoconf
+ ./configure --prefix=/usr
+ sed -i 's/'-Werror'/''/g' Makefile
+
+ if ! grep -q "<linux/delay.h>" $srcdir/crystalhd/driver/linux/crystalhd_flea_ddr.c
+ then
+ sed -i '26i #include <linux/delay.h>' $srcdir/crystalhd/driver/linux/crystalhd_flea_ddr.c
+ fi
+
+ make || return 1
+
+ mkdir -p $pkgdir/etc/udev/rules.d
+ mkdir -p $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
+
+ cp -f 20-crystalhd.rules $pkgdir/etc/udev/rules.d/
+ install -d $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
+ install -m 0644 crystalhd.ko $pkgdir/lib/modules/$(uname -r)/kernel/drivers/video/broadcom
+}
+md5sums=()
diff --git a/abs/not_built/extra/crystalhd-git/crystalhd-git.install b/abs/not_built/extra/crystalhd-git/crystalhd-git.install
new file mode 100644
index 0000000..077905e
--- /dev/null
+++ b/abs/not_built/extra/crystalhd-git/crystalhd-git.install
@@ -0,0 +1,6 @@
+post_install () {
+ depmod -a
+}
+post_upgrade() {
+ post_install
+}