summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/exo
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/exo
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/exo')
-rw-r--r--abs/not_built/extra/exo/PKGBUILD33
-rw-r--r--abs/not_built/extra/exo/exo.install11
2 files changed, 44 insertions, 0 deletions
diff --git a/abs/not_built/extra/exo/PKGBUILD b/abs/not_built/extra/exo/PKGBUILD
new file mode 100644
index 0000000..e4eaf14
--- /dev/null
+++ b/abs/not_built/extra/exo/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 89681 2010-09-03 08:02:13Z remy $
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+# Contributor: tobias <tobias funnychar archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+
+pkgname=exo
+pkgver=0.3.107
+pkgrel=2
+pkgdesc="Extensions to Xfce by os-cillation"
+arch=('i686' 'x86_64')
+license=('GPL2' 'LGPL')
+url="http://www.xfce.org/projects/exo"
+depends=("libxfce4util>=4.6.2" "hal>=0.5.14" 'gtk2' 'hicolor-icon-theme' 'sh')
+makedepends=("pygtk>=2.17.0" 'pkgconfig' 'libnotify' 'perl-uri' 'intltool')
+optdepends=('libnotify: notification support for exo-mount-notify' \
+ 'perl-uri: for mail-compose helper script')
+options=('!libtool')
+install=${pkgname}.install
+source=(http://archive.xfce.org/src/xfce/${pkgname}/0.3/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('3a92cca0c99ee940db4410891c9e8498')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var --disable-static --enable-notifications \
+ --enable-python || return 1
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
diff --git a/abs/not_built/extra/exo/exo.install b/abs/not_built/extra/exo/exo.install
new file mode 100644
index 0000000..21b79d2
--- /dev/null
+++ b/abs/not_built/extra/exo/exo.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}