summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/gpgme
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/gpgme
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/gpgme')
-rw-r--r--abs/not_built/extra/gpgme/PKGBUILD25
-rw-r--r--abs/not_built/extra/gpgme/__changelog1
-rw-r--r--abs/not_built/extra/gpgme/gpgme.install18
3 files changed, 44 insertions, 0 deletions
diff --git a/abs/not_built/extra/gpgme/PKGBUILD b/abs/not_built/extra/gpgme/PKGBUILD
new file mode 100644
index 0000000..6371ad2
--- /dev/null
+++ b/abs/not_built/extra/gpgme/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 48153 2009-07-31 20:34:25Z tpowa $
+# Maintainer: Roman Kyrylych <roman@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+
+pkgname=gpgme
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A C wrapper library for GnuPG."
+arch=('i686' 'x86_64')
+url="http://www.gnupg.org/related_software/gpgme/"
+license=('GPL')
+depends=('libgpg-error>=1.5' 'pth' 'gnupg' 'libassuan')
+install=gpgme.install
+options=('!libtool' '!emptydirs')
+source=(ftp://ftp.gnupg.org/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${pkgdir} install
+ rm ${pkgdir}/usr/share/info/dir
+ gzip ${pkgdir}/usr/share/info/*
+}
+md5sums=('f148c73f6f540f91e02141df72844f62')
diff --git a/abs/not_built/extra/gpgme/__changelog b/abs/not_built/extra/gpgme/__changelog
new file mode 100644
index 0000000..4074d1b
--- /dev/null
+++ b/abs/not_built/extra/gpgme/__changelog
@@ -0,0 +1 @@
+removed gnupg2 requirement
diff --git a/abs/not_built/extra/gpgme/gpgme.install b/abs/not_built/extra/gpgme/gpgme.install
new file mode 100644
index 0000000..b54620d
--- /dev/null
+++ b/abs/not_built/extra/gpgme/gpgme.install
@@ -0,0 +1,18 @@
+infodir=/usr/share/info
+filelist=(gpgme.info gpgme.info-1 gpgme.info-2)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}