summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/libconcord
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/libconcord
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/libconcord')
-rw-r--r--abs/not_built/extra/libconcord/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/not_built/extra/libconcord/PKGBUILD b/abs/not_built/extra/libconcord/PKGBUILD
new file mode 100644
index 0000000..a4b4e2e
--- /dev/null
+++ b/abs/not_built/extra/libconcord/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sven Klomp <mail@klomp.eu>
+# Contributor: Mattheus Happe <mhappe@gmail.com>
+
+pkgname=libconcord
+_pkgsrcname=concordance
+pkgver=0.23
+pkgrel=1
+pkgdesc="Concordance's core functionality contained in a shared library"
+url="http://www.phildev.net/harmony/index.shtml"
+license=("GPL3")
+arch=(i686 x86_64)
+depends=('libusb')
+optdepends=('udev: use libconcord as non-root user')
+source=("http://downloads.sourceforge.net/project/${_pkgsrcname}/${_pkgsrcname}/${pkgver}/${_pkgsrcname}-${pkgver}.tar.bz2")
+md5sums=('d7400d5b351b195b63adfafae68be3d8')
+
+
+build() {
+ cd ${srcdir}/${_pkgsrcname}-${pkgver}/libconcord
+ ./configure --prefix=/usr
+ make || return 1
+ make udev || return 1
+}
+
+package() {
+ cd ${srcdir}/${_pkgsrcname}-${pkgver}/libconcord
+ make prefix=${pkgdir}/usr install || return 1
+ make prefix=${pkgdir}/ install_udev || return 1
+} \ No newline at end of file