summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/mercurial
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/mercurial
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/mercurial')
-rw-r--r--abs/not_built/extra/mercurial/PKGBUILD41
-rw-r--r--abs/not_built/extra/mercurial/__changelog1
-rw-r--r--abs/not_built/extra/mercurial/mercurial.profile1
3 files changed, 43 insertions, 0 deletions
diff --git a/abs/not_built/extra/mercurial/PKGBUILD b/abs/not_built/extra/mercurial/PKGBUILD
new file mode 100644
index 0000000..7c146f5
--- /dev/null
+++ b/abs/not_built/extra/mercurial/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 99614 2010-11-15 21:11:47Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=mercurial
+pkgver=1.7.1
+pkgrel=2
+pkgdesc="A scalable distributed SCM tool"
+arch=('i686' 'x86_64')
+url="http://www.selenic.com/mercurial"
+license=('GPL')
+depends=('python2')
+optdepends=('tk: for the hgk GUI')
+source=(http://www.selenic.com/mercurial/release/${pkgname}-${pkgver}.tar.gz
+ mercurial.profile)
+md5sums=('b14caa0f9e4dd5acbf9e9a6059c37fd3'
+ '43e1d36564d4c7fbe9a091d3ea370a44')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 || return 1
+
+ sed -i -e 's#env python#env python2#' \
+ "${pkgdir}"/usr/lib/python2.6/site-packages/mercurial/lsprof.py
+
+ install -d ${pkgdir}/usr/share/man/{man1,man5}
+ install -m644 doc/hg.1 "${pkgdir}/usr/share/man/man1" || return 1
+ install -m644 doc/{hgrc.5,hgignore.5} "${pkgdir}/usr/share/man/man5" || return 1
+ install -m755 contrib/hgk "${pkgdir}/usr/bin" || return 1
+ install -m644 -D contrib/zsh_completion "${pkgdir}/usr/share/zsh/site-functions/_hg" || return 1
+ install -m644 -D contrib/bash_completion "${pkgdir}/etc/bash_completion.d/hg" || return 1
+ install -d "${pkgdir}/usr/share/emacs/site-lisp"
+ install -m644 contrib/{mq.el,mercurial.el} "${pkgdir}/usr/share/emacs/site-lisp" || return 1
+
+ vimpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm644 contrib/vim/HGAnnotate.vim "${vimpath}/syntax/HGAnnotate.vim" || return 1
+
+ # set some variables
+ install -m755 -d ${pkgdir}/etc/profile.d
+ install -m755 ${srcdir}/mercurial.profile "${pkgdir}/etc/profile.d/mercurial.sh" || return 1
+}
diff --git a/abs/not_built/extra/mercurial/__changelog b/abs/not_built/extra/mercurial/__changelog
new file mode 100644
index 0000000..e0cb121
--- /dev/null
+++ b/abs/not_built/extra/mercurial/__changelog
@@ -0,0 +1 @@
+7/4/11 - chw - change to ensure use of python 2.6 in PKGBUILD
diff --git a/abs/not_built/extra/mercurial/mercurial.profile b/abs/not_built/extra/mercurial/mercurial.profile
new file mode 100644
index 0000000..fc96182
--- /dev/null
+++ b/abs/not_built/extra/mercurial/mercurial.profile
@@ -0,0 +1 @@
+export HG=/usr/bin/hg