summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/mupen64plus-svn
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/mupen64plus-svn
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/mupen64plus-svn')
-rw-r--r--abs/not_built/extra/mupen64plus-svn/PKGBUILD71
-rw-r--r--abs/not_built/extra/mupen64plus-svn/fix-gcc4.4-const-char.patch22
-rw-r--r--abs/not_built/extra/mupen64plus-svn/install.patch13
3 files changed, 106 insertions, 0 deletions
diff --git a/abs/not_built/extra/mupen64plus-svn/PKGBUILD b/abs/not_built/extra/mupen64plus-svn/PKGBUILD
new file mode 100644
index 0000000..5df794d
--- /dev/null
+++ b/abs/not_built/extra/mupen64plus-svn/PKGBUILD
@@ -0,0 +1,71 @@
+#!!! Due to a limitation in pacman's SVN package handling,
+# this package requires out-of-the-ordinary building. pacman checks
+# the SVN repo for new revisions before scanning the PKGBUILD.
+#!!! So, when you run makepkg, if it asks you for a password for 'mupen64',
+# give it 'Dyson5632-kart' without the quotes. If it asks for a password
+# for _your_ username, hit Enter to make it ask for a new username, tell it
+# 'mupen64' without the quotes, and then give it the password above. When
+# it asks you to save the password unencrypted, you can say yes, because
+# it's just a read-only access login :P Once you do that, you shouldn't
+# need to do the above anymore.
+
+# Maintainer: Devin Cofer <ranguvar@archlinux.us>
+# Contributor: Rudy Matela <rudy.matela@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Zephyr
+
+pkgname=mupen64plus-svn
+pkgver=1416
+pkgrel=1
+pkgdesc="Nintendo64 emulator, SVN version"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/mupen64plus/"
+license=('GPL2')
+
+makedepends=('subversion' 'pkgconfig' 'libsamplerate' 'yasm' 'mesa')
+depends=('gtk2' 'sdl_ttf')
+optdepends=('libsamplerate: Higher quality audio')
+conflicts=('mupen64plus')
+provides=('mupen64plus')
+source=('install.patch'
+ 'fix-gcc4.4-const-char.patch')
+md5sums=('f6a3bc6e59d4f2af9db1b3fce257eb43'
+ '7bb0182949bf043847ad7ff66097e66f')
+
+_svnuser=mupen64
+_svnpass=Dyson5632-kart
+_svntrunk=svn://$_svnuser:$_svnpass@fascination.homelinux.net:7684/mupen64plus/trunk
+_svnmod=mupen64plus
+
+build() {
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod &&\
+ svn up --config-dir . -r $pkgver \
+ --non-interactive --username $_svnuser --password $_svnpass)
+ else
+ svn co $_svntrunk --config-dir . -r $pkgver $_svnmod \
+ --non-interactive --username $_svnuser --password $_svnpass
+ fi
+ msg "SVN checkout done or server timeout"
+
+ cp -r $_svnmod $_svnmod-build
+ patch -d $_svnmod-build < install.patch || return 1
+# patch -p0 -d $_svnmod-build < fix-gcc4.4-const-char.patch || return 1
+ cd $_svnmod-build
+
+ make PREFIX="/usr" LIRC=1 all || return 1
+ make PREFIX="$pkgdir/usr" install || return 1
+
+ ##### Qt 4 GUI build #####
+ #==> Currently broken
+ #make PREFIX="/usr" GUI=QT4 all || return 1
+ #install -m755 mupen64plus "$pkgdir/usr/bin/mupen64plus-qt"
+ #
+ #cd "$pkgdir/usr/share/applications"
+ #cp mupen64plus.desktop mupen64plus-qt.desktop
+ #sed -i "s#Name=Mupen64Plus#Name=Mupen64Plus (Qt)#" mupen64plus-qt.desktop || return 1
+ #sed -i "s#Exec=mupen64plus#Exec=mupen64plus-qt#" mupen64plus-qt.desktop || return 1
+ ##### End Qt 4 GUI build #####
+
+ rm -r "$srcdir/$_svnmod-build"
+}
diff --git a/abs/not_built/extra/mupen64plus-svn/fix-gcc4.4-const-char.patch b/abs/not_built/extra/mupen64plus-svn/fix-gcc4.4-const-char.patch
new file mode 100644
index 0000000..fd1495d
--- /dev/null
+++ b/abs/not_built/extra/mupen64plus-svn/fix-gcc4.4-const-char.patch
@@ -0,0 +1,22 @@
+--- glide64/Combine.old.cpp 2009-06-19 17:59:20.191723065 -0400
++++ glide64/Combine.cpp 2009-06-19 18:43:46.955453868 -0400
+@@ -11873,7 +11873,7 @@
+ LOG ("InitCombine() ");
+ memset(&cmb, 0, sizeof(cmb));
+ const char *extensions = grGetString (GR_EXTENSION);
+- if (char * extstr = strstr(extensions, "COMBINE")) {
++ if (const char * extstr = strstr(extensions, "COMBINE")) {
+ if (!strncmp(extstr, "COMBINE", 7)) {
+ LOG ("extensions ");
+ cmb.grColorCombineExt = (GRCOLORCOMBINEEXT) grGetProcAddress("grColorCombineExt");
+--- glide64/Main.old.cpp 2009-06-19 18:47:04.238930057 -0400
++++ glide64/Main.cpp 2009-06-19 18:47:18.018772876 -0400
+@@ -784,7 +784,7 @@
+ printf("bebefore2\n");
+ if (settings.fb_hires)
+ {
+- if (char * extstr = strstr(extensions, "TEXTUREBUFFER"))
++ if (const char * extstr = strstr(extensions, "TEXTUREBUFFER"))
+ {
+ if (!strncmp(extstr, "TEXTUREBUFFER", 13))
+ {
diff --git a/abs/not_built/extra/mupen64plus-svn/install.patch b/abs/not_built/extra/mupen64plus-svn/install.patch
new file mode 100644
index 0000000..5e41460
--- /dev/null
+++ b/abs/not_built/extra/mupen64plus-svn/install.patch
@@ -0,0 +1,13 @@
+Index: install.sh
+===================================================================
+--- install.sh (revision 1295)
++++ install.sh (working copy)
+@@ -90,7 +90,7 @@
+ if [ -f mupen64plus.desktop ]
+ then
+ $INSTALL -d -v "${APPLICATIONSDIR}"
+- $INSTALL -m 0644 mupen64plus.desktop "${APPLICATIONSDIR}"
++ $INSTALL -m 0644 mupen64plus.desktop "${APPLICATIONSDIR}/mupen64plus.desktop"
+ fi
+ if [ "x$(ls plugins/)" != "x" ]
+ then