summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/mupen64plus
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/mupen64plus
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/mupen64plus')
-rw-r--r--abs/not_built/extra/mupen64plus/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/not_built/extra/mupen64plus/PKGBUILD b/abs/not_built/extra/mupen64plus/PKGBUILD
new file mode 100644
index 0000000..c7835c0
--- /dev/null
+++ b/abs/not_built/extra/mupen64plus/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 78487 2012-10-19 16:17:59Z jelle $
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Zephyr
+
+pkgname=mupen64plus
+pkgver=1.99.5
+pkgrel=3
+pkgdesc='Nintendo64 Emulator'
+arch=('i686' 'x86_64')
+url='http://code.google.com/p/mupen64plus/'
+license=('GPL')
+depends=('glu' 'libgl' 'libsamplerate' 'libpng' 'sdl' 'freetype2')
+makedepends=('mesa')
+source=("http://mupen64plus.googlecode.com/files/mupen64plus-bundle-src-${pkgver}.tar.gz")
+md5sums=('93772a6d6fc6a63353462deae8a6db71')
+
+build() {
+ cd mupen64plus-bundle-src-${pkgver}
+
+ sh m64p_build.sh
+}
+
+package() {
+ cd mupen64plus-bundle-src-$pkgver
+
+ # set LDCONFIG since we are using fakeroot and scripts run root commands by checking the uid
+ ./m64p_install.sh DESTDIR="$pkgdir" PREFIX='/usr' MANDIR='/usr/share/man/man6' LDCONFIG='true'
+}
+
+# vim: ts=2:sw=2:et