summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/phonon
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/phonon
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/phonon')
-rw-r--r--abs/not_built/extra/phonon/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/abs/not_built/extra/phonon/PKGBUILD b/abs/not_built/extra/phonon/PKGBUILD
new file mode 100644
index 0000000..40b13d2
--- /dev/null
+++ b/abs/not_built/extra/phonon/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id$
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgbase=phonon
+pkgname=('phonon' 'phonon-xine' 'phonon-gstreamer')
+pkgver=4.4.2
+pkgrel=3
+arch=('i686' 'x86_64')
+url="http://phonon.kde.org"
+license=('LGPL')
+makedepends=('cmake' 'automoc4' 'qt' 'xine-lib' 'gstreamer0.10-base-plugins' 'mesa')
+source=("http://download.kde.org/stable/${pkgname}/${pkgver}/${pkgbase}-${pkgver}.tar.bz2")
+sha1sums=('c329d924fb75a89a9de8a4d799ff4dcd7ee3302e')
+
+build() {
+ cd ${srcdir}
+ mkdir build
+ cd build
+ cmake ../${pkgbase}-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DWITH_PulseAudio=OFF
+ make
+}
+
+package_phonon(){
+ pkgdesc="The multimedia API for KDE4"
+ depends=('qt' 'phonon-backend')
+ cd ${srcdir}/build/phonon
+ make DESTDIR=${pkgdir} install
+ cd ${srcdir}/build/includes
+ make DESTDIR=${pkgdir} install
+ cd ${srcdir}/build
+ install -Dm644 phonon.pc ${pkgdir}/usr/lib/pkgconfig/phonon.pc
+}
+
+package_phonon-gstreamer(){
+ pkgdesc="Phonon Gstreamer backend"
+ depends=('qt' 'gstreamer0.10-base-plugins')
+ provides=('phonon-backend')
+ cd ${srcdir}/build/gstreamer
+ make DESTDIR=${pkgdir} install
+}
+
+package_phonon-xine(){
+ pkgdesc="Phonon Xine backend"
+ depends=('qt' 'xine-lib')
+ provides=('phonon-backend')
+ cd ${srcdir}/build/xine
+ make DESTDIR=${pkgdir} install
+}
+