summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/unetbootin
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/unetbootin
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/unetbootin')
-rw-r--r--abs/not_built/extra/unetbootin/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/not_built/extra/unetbootin/PKGBUILD b/abs/not_built/extra/unetbootin/PKGBUILD
new file mode 100644
index 0000000..2978b54
--- /dev/null
+++ b/abs/not_built/extra/unetbootin/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Det <nimetonmaili at gmail a-dot com>
+# Contributor: Godane aka Christopher Rogers <slaxemulator@gmail.com>
+
+pkgname=unetbootin
+pkgver=494
+pkgrel=1
+pkgdesc="Allows the creation of bootable Live USB drives for Linux/BSD distributions"
+url="http://unetbootin.sourceforge.net/"
+license="GPL"
+arch=('i686' 'x86_64')
+depends=('syslinux' 'p7zip' 'qt' 'mtools')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-source-${pkgver}.tar.gz)
+md5sums=('e3f01fd88f3aa5d918c60ba0be608e86')
+
+build() {
+ cd "${srcdir}"
+ sed -i '/^RESOURCES/d' unetbootin.pro
+ lupdate unetbootin.pro
+ lrelease unetbootin.pro
+ qmake "DEFINES += NOSTATIC" "RESOURCES -= unetbootin.qrc"
+ make
+}
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/sbin"
+ install -m 755 ${pkgname} "${pkgdir}/usr/sbin/${pkgname}"
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ install -m 644 unetbootin_*.qm "${pkgdir}/usr/share/${pkgname}"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ install -m 644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/"
+ sed -i 's|Exec=/usr/bin/unetbootin|Exec=su -c /usr/sbin/unetbootin|g' "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ sed -i 's|Terminal=false|Terminal=true|g' "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
+