summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/wxpython
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/wxpython
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/wxpython')
-rw-r--r--abs/not_built/extra/wxpython/ChangeLog48
-rw-r--r--abs/not_built/extra/wxpython/PKGBUILD33
-rw-r--r--abs/not_built/extra/wxpython/editra-aui.diff11
3 files changed, 92 insertions, 0 deletions
diff --git a/abs/not_built/extra/wxpython/ChangeLog b/abs/not_built/extra/wxpython/ChangeLog
new file mode 100644
index 0000000..02c759e
--- /dev/null
+++ b/abs/not_built/extra/wxpython/ChangeLog
@@ -0,0 +1,48 @@
+2010-08-21 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.11.0-2
+ * Rebuilt for python2
+
+2010-06-03 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.11.0-1
+ * Upstream update
+
+2010-05-08 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.10.1-2
+ * Rebuilt against wxgtk 2.8.11
+ * Added mediactrl support (close FS#18522)
+
+2009-05-18 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.10.1-1
+ * Upstream update
+ * Added patch for editra
+
+2009-05-05 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.9.2-2
+ * Rebuilt against wxgtk 2.8.10
+
+2009-03-06 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.9.2-1
+ * Upstream update
+
+2008-10-28 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.9.1-1
+ * Upstream update
+ * Python 2.6 rebuild
+
+2008-08-19 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.8.1-1
+ * Upstream update
+
+2008-07-05 Eric Belanger <eric@archlinux.org>
+
+ * wxpython 2.8.8.0-1
+ * Upstream update
+ * Added ChangeLog
diff --git a/abs/not_built/extra/wxpython/PKGBUILD b/abs/not_built/extra/wxpython/PKGBUILD
new file mode 100644
index 0000000..b9375cc
--- /dev/null
+++ b/abs/not_built/extra/wxpython/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 88207 2010-08-21 05:14:19Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Andrew Wright <andreww@photism.org>
+
+pkgname=wxpython
+pkgver=2.8.11.0
+pkgrel=2
+pkgdesc="A wxWidgets GUI toolkit for Python"
+arch=('i686' 'x86_64')
+license=('custom:wxWindows')
+url="http://www.wxpython.org"
+depends=('wxgtk' 'python2')
+makedepends=('mesa')
+changelog=ChangeLog
+source=(http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2 editra-aui.diff)
+md5sums=('63f73aae49e530852db56a31b57529fa' '06c637c34c1570d8c82b870ce19c0622')
+sha1sums=('18982edc236a1d87e4eef018928358c925aa5b17' '077fe341bf8822647934d6b1ea82ce9b0adbf93a')
+
+build() {
+ cd "${srcdir}/wxPython-src-${pkgver}"
+ patch -p1 < ../editra-aui.diff
+ ./configure --prefix=/usr --libdir=/usr/lib --with-gtk=2 --with-opengl --enable-unicode \
+ --enable-graphics_ctx --with-gnomeprint --disable-optimize --enable-mediactrl \
+ --with-libpng=sys --with-libxpm=sys --with-libjpeg=sys --with-libtiff=sys
+ cd "${srcdir}/wxPython-src-${pkgver}/wxPython"
+ python2 setup.py WXPORT=gtk2 UNICODE=1 build
+}
+
+package() {
+ cd "${srcdir}/wxPython-src-${pkgver}/wxPython"
+ python2 setup.py WXPORT=gtk2 UNICODE=1 install --root="${pkgdir}"
+ install -D -m644 ../docs/licence.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/not_built/extra/wxpython/editra-aui.diff b/abs/not_built/extra/wxpython/editra-aui.diff
new file mode 100644
index 0000000..afdcf9f
--- /dev/null
+++ b/abs/not_built/extra/wxpython/editra-aui.diff
@@ -0,0 +1,11 @@
+diff -Naur wxPython-src-2.8.11.0-orig/wxPython/setup.py wxPython-src-2.8.11.0/wxPython/setup.py
+--- wxPython-src-2.8.11.0-orig/wxPython/setup.py 2010-06-04 04:15:47.000000000 -0400
++++ wxPython-src-2.8.11.0/wxPython/setup.py 2010-06-04 04:18:36.000000000 -0400
+@@ -893,6 +893,7 @@
+ 'wx.tools.Editra.src.eclib',
+ 'wx.tools.Editra.src.ebmlib',
+ 'wx.tools.Editra.src.extern',
++ 'wx.tools.Editra.src.extern.aui',
+ 'wx.tools.Editra.src.syntax',
+ ]
+