summaryrefslogtreecommitdiffstats
path: root/abs/not_built/extra/xmbmon
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-01 18:26:22 (GMT)
commite2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37 (patch)
treebee3fe89f2988dd244e11791755e129aa8c03b14 /abs/not_built/extra/xmbmon
parent8132c218cfc1f1acb1c6d12154e0d4ca075e77f2 (diff)
downloadlinhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.zip
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.gz
linhes_pkgbuild-e2c33b0fae1fa4af8bbbfc917eb8e13a3ac0cb37.tar.bz2
Mass move of uncompiled packages to abs_not_built.
The will sit here for a bit, and then will be removed completely if no one claims them.
Diffstat (limited to 'abs/not_built/extra/xmbmon')
-rw-r--r--abs/not_built/extra/xmbmon/Makefile.in.patch37
-rw-r--r--abs/not_built/extra/xmbmon/PKGBUILD20
2 files changed, 57 insertions, 0 deletions
diff --git a/abs/not_built/extra/xmbmon/Makefile.in.patch b/abs/not_built/extra/xmbmon/Makefile.in.patch
new file mode 100644
index 0000000..be3bf73
--- /dev/null
+++ b/abs/not_built/extra/xmbmon/Makefile.in.patch
@@ -0,0 +1,37 @@
+diff -ru xmbmon205.orig/Makefile.in xmbmon205/Makefile.in
+--- xmbmon205.orig/Makefile.in 2004-08-13 17:04:21.000000000 +1000
++++ xmbmon205/Makefile.in 2008-06-14 00:59:35.000000000 +1000
+@@ -37,11 +37,11 @@
+ RM=rm -f
+ INSTALL=install
+
+-INST_DIR=/usr/local/bin
+-INST_MANDIR=/usr/local/man/man1
+-INST_XDIR=/usr/X11R6/bin
+-INST_MANXDIR=/usr/X11R6/man/man1
+-INST_XRDIR=/usr/X11R6/lib/X11/app-defaults
++INST_DIR=/usr/bin
++INST_MANDIR=/usr/share/man/man1
++INST_XDIR=/usr/bin
++INST_MANXDIR=/usr/share/man/man1
++INST_XRDIR=/usr/lib/X11/app-defaults
+
+ .c.o:
+ $(CC) -c $(CFLAGS) $*.c
+@@ -133,12 +133,12 @@
+ $(RM) Makefile config.cache config.log config.h config.status
+
+ install: $(PROGRAM)
+- $(INSTALL) -o root -g wheel -m 4555 -c -p mbmon $(INST_DIR)
+- $(INSTALL) -o root -g wheel -m 4555 -c -p xmbmon $(INST_XDIR)
++ $(INSTALL) -o root -g wheel -m 4555 -c -p mbmon $(DESTDIR)$(INST_DIR)
++ $(INSTALL) -o root -g wheel -m 4555 -c -p xmbmon $(DESTDIR)$(INST_XDIR)
+
+ install-man: $(MANPAGE)
+- $(INSTALL) -o root -g wheel -m 444 -c -p mbmon.1 $(INST_MANDIR)
+- $(INSTALL) -o root -g wheel -m 444 -c -p xmbmon.1x $(INST_MANXDIR)
++ $(INSTALL) -o root -g wheel -m 444 -c -p mbmon.1 $(DESTDIR)$(INST_MANDIR)
++ $(INSTALL) -o root -g wheel -m 444 -c -p xmbmon.1x $(DESTDIR)$(INST_MANXDIR)
+
+ lint:
+ $(LINT) $(INCLUDES) $(DEFS) $(FONTDEFINES) $(SRCS) -lm
diff --git a/abs/not_built/extra/xmbmon/PKGBUILD b/abs/not_built/extra/xmbmon/PKGBUILD
new file mode 100644
index 0000000..348094b
--- /dev/null
+++ b/abs/not_built/extra/xmbmon/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: Jonathan Liu <net147@hotmail.com>
+pkgname=xmbmon
+pkgver=2.05
+pkgrel=2
+pkgdesc="X Motherboard Monitor"
+arch=('i686' 'x86_64')
+url="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.html"
+license=('GPL')
+source=(http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/xmbmon/xmbmon205.tar.gz
+ Makefile.in.patch)
+md5sums=('ab6614c785f5b653fcc69fb9c02058f0'
+ 'e417a1a04b95bc3505b74a52faa54c4a')
+
+build() {
+ cd $startdir/src/xmbmon205
+ patch -Np1 -i $startdir/src/Makefile.in.patch
+ ./configure
+ mkdir -p $startdir/pkg/usr/{bin,share/man/man1}
+ make DESTDIR=$startdir/pkg install install-man || return 1
+}