summaryrefslogtreecommitdiffstats
path: root/abs/chroot-devel/terminal/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/chroot-devel/terminal/PKGBUILD')
-rw-r--r--abs/chroot-devel/terminal/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/chroot-devel/terminal/PKGBUILD b/abs/chroot-devel/terminal/PKGBUILD
new file mode 100644
index 0000000..9f17eee
--- /dev/null
+++ b/abs/chroot-devel/terminal/PKGBUILD
@@ -0,0 +1,25 @@
+
+pkgname=terminal
+pkgver=0.2.8
+pkgrel=3
+pkgdesc="A modern terminal emulator primarly for the Xfce desktop environment"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.xfce.org/projects/terminal/"
+groups=('xfce4')
+depends=('exo>=0.3.4' 'vte>=0.16.14' 'dbus-glib>=0.76'
+ 'hicolor-icon-theme')
+makedepends=('pkgconfig')
+options=('!libtool')
+install=terminal.install
+source=(http://www.xfce.org/archive/xfce-4.4.2/src/Terminal-${pkgver}.tar.bz2
+ terminal-dont-die-on-dbus-kill.patch)
+
+build() {
+ cd ${srcdir}/Terminal-${pkgver}
+ patch -Np0 -i ${srcdir}/terminal-dont-die-on-dbus-kill.patch || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var --disable-static || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}